X-Particles too jiggly with it


#1

Hey guys

Working on a simple paste simulation in x-particles using constraints and Fluidpbd and in general its about what I’m wanting but the particles just keep vibrating after they should settle, to the point where the start of the paste sometimes slowly raises into the air, oddly. I’ve tweaked every setting I can think makes a difference. I’ve attached the scene, if anyone has any insights, I’d greatly appreciate it. PasteTest.zip (67.0 KB)


#2

Here’s the thing. I know exactly how to help you and can tell you exactly what to do to solve your issue. I’ve come across it myself and had to work it out.

But I’m not going to give you the help because @joeldubin, @cmyk, @simonfarussell and @Cairyn would rather I didn’t post here any more.

I’ll let them help you.

It’s a 5 min fix and you’ll kick yourself when you find out the answer.


#3

Quick update, I switched from FuidPBD to FluidFX and it seems much more stable. I need to look into what the difference is between these to fluid solvers, but this puts me very close to what I want. I’d still like to know why those particles are insane.


#4

Um, ok. But you just posted…

Anyway, I’m sure it is and I’m sorry for the drama here. I have no idea what’s going on.

Thanks!


#5

F**k it, you’re right. You’re not the problem ignore my previous comment.

Use a freeze or drag modifier and use the data mapping mapped to a suitable parameter to control when the particle comes to a rest. I tend to use the Drag modifier with particle age mapping so the particle comes to a controlled stop.


#6

I thought freezing the particles might be the answer but they’re vibrating so fast, I wasn’t sure that was it. Thanks!


#7

The trick is to use the data mapping a lot to keep control of your particles. You can even use it by mapping drag to velocity to keep them under control of the simulation as a damping effect so the simulation never gets out of control.

I suspect the real issue is simulation accuracy but that obviously increases the calculation time so I prefer this little ‘workaround’ that just nudges things in the right direction.


#8

@Infograph, FTR, I only asked you tone down your rhetoric. I wouldn’t ask anyone to not post here anymore as it’s not my place, anyhow.

You’re angst and emotions over the current state of Maxon seems to be getting in the way of just being helpful here, and that’s a shame since you’re obviously skilled. Glad you helped a fellow C4Der out, regardless.


#9

Ok, so I found 2 solutions that look good, one using a different approach to the PBD and another using the FluidFX solver.

FluidFX solver just worked.

In the PBD, lowering the viscosity in PBD and cranking the viscosity in the emitter under Extended Data>Fluid Data to an extreme amount as well as cranking up the iterations in the project settings to 25 is the key. Thanks to Lothar in the xparticles forums for that.

Both attached, hope this helps someone!

PasteTestPBD.zip (44.4 KB)
PasteTestFluidFX.zip (46.2 KB)


#10

Awesome stuff Infograph! This sharing of knowledge and helping one another is what makes this community great! More signal, less noise!


#11

I totally agree with that, it becomes an entirely different sim with every tick of the subframes and iterations tweak.

Thanks again for the tips, Info!


#12

Dont believe I asked you to not post here any more. Was sharing my opinion on the direction and tone of the other thread. Nice solution infograph.

Hey Troyan—I had to do the same thing a while back and used viscosity. I dont remeber having that vibrate issue. 'll see if I can find the file (although it seems you;ve solved it)


#13

Appreciate it, Joel, I think I’m on to a good sim, but always love to see how everyone else approaches things.


#14

FWIW–I did this about 5 years ago. There are probably better ways to approach.

viscosity.c4d (191.7 KB)