Working in 1cm=1cm scale in bifrost


#1

Hello,

I lately decided to study Mayas bifrost system (finally!) and I can get it working properly with a simple scene, but now when I need it in a real scene I crashed into a problem.

I’ve created an archviz scene with a pool and I’d like to use bifrost to create nice looking water into it. I’ve modeled my scene in cm scale (maya units set to cm) and my pool is 6 by 10 meters. So in maya units it equals 1000 by 600. This creates a problem when starting bifrost. It asks me if I’m sure I want to create a scene such big (in this point I think it thinks the scene as 1000 meters by 600 meters, am I right?), if I click no, nothing happens and I cant get any simulation to work. If I click yes, it takes around 5minutes to calculate and nothing still happens. Even though every time I make a change in the scene it takes again 5 minutes to calculate again. It may be happening because I’m running out of memory at that time. Bifrost is set to be using 12gb out of 16 available and it is using it all when I start it.

I think 6 by 10 meters scene shouldnt be too big for bifrost even with my computer (I’ve been using larger scenes in realflow). Is there any solution to work this out?

Thank you for any replies in advance, it’s my first post and I try to pay back if possible any time soon.

Cheers,
Ontto


Maya what are default scale settings for mash ncloth xgen bifrost dynamics, and what scale do modellers ,animators,use?
#2

a bifrost unit is 1meter even maya is set to 1cm


#3

Surely there’s a scale setting, like all other Maya dynamics? Making people rescale their scenes to use one particular feature would be crazy.

(For that matter, it’s too bad that they’re adding more systems with nonstandard scale–new features should default to 1cm scale to move towards uniform units.)


#4

Bifrost 1unit=1meter & i think it’s independent from Maya scene scale unit (i.e if you set 1unit = 1cm, 1m, 1inch, 1foot etc. bifrost will remain 1unit=1meter).


#5

It’s the Maya plugin’s job to translate scale (not the user’s). I understand that they aren’t trying to integrate every feature of Bifrost at once, but this is basic stuff.


#6

Is my only option really to scale whole scene to a scale of 0.01 to make bifrost working? It sounds truly kinda strange.


#7

in simulation world scale is not “basic”… they fucked up the maya scaling on maya 1.0 and now there is no easy way to fix it…

https://knowledge.autodesk.com/support/maya/learn-explore/caas/CloudHelp/cloudhelp/2016/ENU/Maya/files/GUID-CD0DCC36-14A6-438F-99F4-4A559B5EDB4B-htm.html

//youtu.be/eHogPqINPwQ


#8

It’s the Maya plugin, not the simulation. You convert units in the plugin as data passes between Maya and the simulation. Not having any scale factor is nuts.

they fucked up the maya scaling on maya 1.0 and now there is no easy way to fix it…

Nothing is easy in Maya development, but this isn’t terribly difficult. Add an attribute somewhere with the scene scale in meters (eg. 0.01 for the default cm scale), and when new dynamics systems are created, connect it to the scale factor of the sim. That way, new simulations will use the scene scale, and legacy ones will stay the same.

(Of course, it needs a scale factor attribute to connect to, like the one nucleus nodes have.)


#9

I could not help but chuckle when I saw this thread, another classic Autodesk " lets buy a plugin “attitude” but who cares about the scaling . This is why now nearly every shop uses Houdini over Maya for FX .

b


#10

There is really only one thing that needs to be adjusted for units = cm: make the gravity 980.0


#11

Increasing gravity will stop it running out of memory? (It sounded like he needed to decrease the voxel size.)


#12

so if I made a scene to scale (1 unit = 1 cm)

made a seperate BOSS or bifrost scene, imported the objects needed for the simulation into my BOSS/bifrost scene/
Scale down those objects to a factor of 0.01
do the simulation.
cache out the geometry and everything that is needed.

import this back into the original to scale scene
scale the simulation plane up by 100.

would i then have a correct scene to render in?