Vieport Display issue


#1

Hi,

I’m experiencing a viewport display issue. My scene has been imported as a dwg file (autocad).
While I’m using ortographic or top/bottom/right or left, everything works fine. But When I switch to perspective, or camera view, the geometry starts to look strange (see image attached). The other image shows what happens when I switch to ortographic view. It only happens in this scene.
System units - metric, 1unit - 1mm. Size of the building is ok, around 6m height according to the ‘tape’ tool.

Whole geometry is moved to the origin, it’s right in the centre.
There is indeed a strange error showing while rendering that ‘bounding box too large’ but I checked many times, tried even to edit poly of the whole scene, and none of the vertices seems to be very far from my scene, nor any object. Zoom extens all shows only the visible part of the scene that is shown in these pictures.

any clue how can I solve this problem?
thanks!


#2

Merge this into a new scene with scene units set to Meters. If you have cm/mm/inches as scene units this will cause items to look like this in perspective view when working on something as large as this.

Just be aware of the caveats - if you merge in items from other scenes that are not xform reset or have modifiers that are built and rely on different units they will not import correctly. Same with if you need to use items from this scene in another scene with different units. If you prefer to keep things in the same units you will have to put up with it and work in isometric view (I do this as it can become messy when merging items across different scenes from interiors/exteriors and library assets).


#3

You…are…my…man! I owe You a beer.
I did what You said and it looks good now…Before importing had to change both display and system unit scale to meters. You were right.
Thank You! !

By the way - is there any chance that all materials used in the merged scene will be put into material editor slots?
I kept all materials there, made a new scene, merged all objects, but the materials remaining in the slots are no longer being used, these are just clones of the originals…


#4

aslong as its an 8%+ Beer :slight_smile:

You can have your display units how you want, just the scene units are important. Its basically (among other things) it knows how to calculate the front/back face as you zoom in/out - which otherwise causes z fighting.

No you will lose your material editor slots, best method is to just go back to your previous scene, create a new material .mat file and drag and drop them into it, save it, load your new scene and your .mat file should still be open, you can then drag these back into the material editor slots.

If you have made your materials in real-world units (instead of Tile 1:1 it will be like Tile 30mm:30mm) These will be all out of scale by a factor of what you changed your units from - just another warning about scene units.


#5

Actually sorry I just understood what you said last when I re-read it. Can you not eye drop the items you want to change the materials from?

Can you show a screenshot of what you mean by:

“I kept all materials there, made a new scene, merged all objects, but the materials remaining in the slots are no longer being used, these are just clones of the originals…”


#6

Much appreciate Your help, Thanks a lot.
If all of our problems were solved so quickly…
Good luck mate, it’s 8% + 2 beers then :slight_smile:


#7

If I understand you correctly this could work…

Once you make the .mat file and you have it open, right click on the .mat title and select ‘Update Scene Materials from Library’.

Looks like you can also add all the current items from your previous scene by selecting the next item down "Get All Scene Materials/Maps’ as well. Forget more than you know sometimes :smiley:


#8

Wow…looks easy and works fine.
Another beer! :slight_smile:


#9

:ok_hand:


#10

Funny thing is, that when You import this model into the scene where you had previously changed all units to meters, You can still change system units - 1unit to 1mm inside this scene, and You still have good display.
I did that to try because all my camera units became strange - i.e. camera focal lenght instead of being 43mm changed to 0.04. So chaning units within the scene, after merging geometry, does not affect the display in any way, but it will let using other tool’s unit settings like they are in original state…


#11

This is why you should import it into a fresh scene. Changing system units within the same scene will cause things to go funky.

Also, as I mentioned earlier about caveats - you will encounter many other issues between scenes when system units change. It can definately break a pipeline so use with caution. I myself keep the same system units regardles of the scene I work in (cm) and when working on large sites like this just use isometric view instead of perspective to avoid the zfighting - I prefer the trade off of having a bad viewport compared to messing with system units.

Each to their own, you have the choice but there is always a consequence. Sometimes (rarely) I have to have different scenes in different units but then xform and merge to ensure there is no scale issues, unfortunately if you use any real-world uvw’s these will scale incorrectly, same with any modifiers you wish to keep that rely on scene units, so the options are limited when it comes to this workflow - if you are aware of the consequence you can make the choice that suits you best.