Understanding PLA Keys & the Time Track


#1

Hi,

I’m trying to create a stepped effect with PLA and the Time Track. I would like to advance time at specific frames, but it’s not working with my current scene. I want the first movement to happen at the 2nd frame, so I create a stepped key on frame 2 of the Time Track and set the value to 4%. I won’t see movement in the character, however, until frame 3. My scene is attached below. In it you can also see that even though time is advancing %-wise, the Time Track keyframes at frames 29, 35, 41, 47 do nothing. If the animation is linear mode, the Time Track’s % keyframes work as expected. Is there a way to get this working in stepped key mode? Is this a bug?

Animated Teapot_.zip (1.1 MB)


#2

I think this is unintended behavior or a bug. It seems that C4D does some bad rounding of the time track with hold keyframes, so that it’s not very exact.
I only know a workaround, not really a solution.
-Select all the timetrack keyframes.
-Disable “enable frame snappping” timeline->edit->enable frame snapping
-move all keyframes just a little to the left. so that the keyframes are timed just before the frame. (1.9F, 3.9F, 5.9F etc.)

That seemed to work when I tried it on your project (in R20)

Also, try sending a bug report with that project


#3

Hi @mart1jn,
Thanks for the response. I will try what you’re describing.

I did send this project as a bug report and the support person said the same thing about the rounding not being exact. My response was that the issue is not in the accuracy, but in the behavior of the keyframes when in Linear vs. Stepped Mode. Hopefully they will add it as a bug so it gets fixed!