TurbulenceFD: Can you clone the container?


#1

Hi all,

I have been using this amazing tool for a while now, and I can do just about anything I want with it. However:

One of the issues I have had (there are only a few in my time with the eval over that past couple months) is this:

I cannot seem to get the TFD Container, with a cached sim, to work with a Mograph Cloner or Mograph Instance.

I need to clone a bunch of cached sims of dust/smoke plumes, all in a row, and offset their timing, so they do not happen all at once, but in order.

The time offest isn’t really the issue, though… The issue is THEY DO NOT RENDER AT ALL. Only the original will render, not any of the clones/instances.
I tried using Xref, I tried using Render Instances (and not using them), I tried cloning to an object for position, as well as using the default Linear Cloner, etc.

Sooooo. Is this even possible?

I can see the fluid cache play over time, so I know I am loading the cache correctly (works by itself and with an XRef).
What I can’t do is get it to render the multiple copies. It only ever renders the very first one.

Anyone have any ideas what I am either doing wrong, or if this just isn’t possible?
I posted on the Jawset forum but no replies.

Thank you for any help,

Perry


#2

works fine:
i cloned a container, converted it, and voila, get 3 single containers (all with the same cache of course).
after that you can set anything you want (offset, cache-file etc) via xpresso.

let me know of you need further help.
hth
fuat


#3

When you say you ‘converted’ the container, what do you mean by that?
Do you mean you made it editable?

Also, you didn’t mention if the containers render (because I see them all there within the
Cloner as well, they just don’t show up when I render).

Thanks so much for trying it out and for the offer to help!

Perry


#4

So assuming you meant to make it editable, I tried that, and it still didn’t work.
The only thing that worked was making the Cloner Editable, which defeats the
purpose of using the Cloner in the first place, since I need to use Render Instances if at all possible since these are fairly heavy cached sims.

Thanks again, looking forward to hearing what you meant and it
it did render for you.

Perry


#5

with converting i meant

  • select cloner
  • hit “C”-key

are you sure you assigned the right channel in the TFD-Container -> Rendering Tab -> Smoke Shader (or -> Fire Shader)? i guess this is why you cant see anything.
and in the render settings, do have TFD Renderer checkbox activated?
these two are the only reasons i can think of why you dont get it rendered.

see attached images.
fuat


#6

Thanks for the reply.
That is what I thought you meant.

The problem with that is it kills all the “history” when it is made editable (hitting hte “C” key)
and therefore any animation or changes I might want to make to the cloner are gone.
The other (bigger) problem with doing that is that they are not instances any more
but
distinct separate copies of the clontainer, which uses a ton more memory and
kills interactivity. I would basically get the same result just manually copying the container and pasting it, when I really need instances instead.

Also, just to answer your other questions: Yes, both the fire shader being assigned in the Rendering tab and also the TurbulenceFD renderer in the C4D render settings are correct.

Thanks anyway, and I really appreciate you trying to help!

Perry


#7

So in far less words, what I want to know is:

Does TurbulenceFD work with Rendertime Instances in Cinema 4D?

Thank you for any help!


#8

not that i am aware of, Perry.
but maybe try contact Jascha directly again?

Fuat


#9

I’m not 100% sure, but aren’t those converted clones somehow instances since they all are instancing the same cachefile? I mean, there are not several simulations in the scene. They all point to the same cache which should be like an instance, right? I had a project where we had to place a lot (about 300) of little fires in a scene. So we simulated one fire, cloned the container, converted the cloner and offsetted the timing of all the TFD containers. Rendered without a problem on a normal machine.

Cheers
Simon


#10

Thanks teleliq and fuat.

teleliq, as far as I know, if it isn’t really a rendertime instance, it has to keep
all the cache file in memory for every tile of the render, so even though it points to the same one, it has to have “awareness” of them all for every tile. If it is a Rendertime Instance,
tradtionally (not sure if C4D or TFD works this way) that meant that the instance was only called into memory on an as-needed basis per render tile.

Perhaps this isn’t the way either C4D or TFD (or both!) work, but my instincts are that it is.

I certainly don’t want to bug Jascha, since I haven’t even purchased the plugin, this is all
based on evalulation copy. I just want to make sure it will fit my needs before I purchase it.

Thank you both for the help!


#11

from production side i know that if you have an extremely hires-sim, even with a high-end gpu you can run into viewport refreshing lags when navigating, even with one single container. so i sometimes end up navigating with a low res reference cache loaded and for rendering switch to the hires sim.
having this in mind i assume that your instinct is right, Perry (no harm intended, Simon ;)), since a ref like an vray mesh for example does it it even with millions of proxies without any OGL issues and i dont think that this is the case with TFD - even if it´s a pointer to the cache, the grid-scalar-values have to be loaded into the GPU to guarantee a proper visual feedback of the channels i assume - so loading a lowres representation of the SDF could be an alternative.
but only my gutfeeling and still an interesting question.

fuat


#12

Because you guys were so awesome last time with trying to help,
I thought I would ask a (slightly) different question if you don’t mind?

I now have thee containers with cached sims (each one is the same sim, just offset in time).
I am running into problems rendering because they overlap. I can’t seem to solve this any other way than to render them separately. This isn’t ideal because they will look flat that way, even though they are volumetric, since the point of overlapping them was to fill out the volume and make it look like a more complicated sim.

I get very faded or black areas where they overlap.
I am doing a fire render, so it is very clear where the bounding box of the container is and that it is making the fire within that aread (on both containers) go very dark or black.

Anyone else see this happen before?

Thanks for any help you can give!


#13

i assume the black area comes from the mapping in the fire shader, true? if so, try to change the mapping (making it less opaque in areas where the shader is black).
what fire-shader do you use? blackbody?
the viewport gives you a very good representation of the scalar value in each voxel, which then is used for rendering.
only a guess of course without seeing any screenshot.
hth
fuat


#14

Thanks for the reply, Fuat!

I checked and thanks to your suggestion solved the problem.
The ‘Separate Opacity’ slot had been set to ‘X Gradient’ and the curve was basically
a step at the 50% mark, so opacity just dropped off in a very binary way.

It did the trick to cut the opacity of the sim off halfway along the X axis, which is what
I wanted, but gave me the unintended result I described above.

Thanks so much, again, for the help!


#15

Kool.
.


#16

So, I am no way an expert, and I could not figure out from this discussion whether you I can use a cloner with TurbulabceFD container. And if so, how can I? My project has quite a few cells in which I place burning candles. The flam is created with TFD container. I stumble on the same issue - they won’t show in render. I am not sure what setting I need to set up in the Rendering tab under Smoke Shader. Can you guys help?


#17

Export the sim to a VDB and import it as many times as you need. You can add variation with different shaders so they don’t all look identical.


#18

Thank you so much! Don’t stone me, but what is VDB?


#19

A VDB or OpenVDB is just a format for storing gridded volumetric data. It’s the industry standard for baking fluid sims into. I’m sure Turbulence has an option somewhere to cache or export a VDB.


#20

Thank you so much! Still struggling with this. I managed to convert the cache files into VDB. I now have 400 VDB files. Not sure what to do next.