Trouble with Silo


Im having problems with the displacement brush tool.

I just migrated to a new computer. Ive used silo for many years. I also use the displacement painting tool A LOT in my models. It always used to be (on my old machine) that shift and mouse would smooth the mesh while the brush tool was enabled, but now instead of smoothing it, its doing the opposite (adding noise) Its like somehow, internally, they got reversed. This is forcing me to swap to a smooth brush and smooth it (which is taking longer… would prefer to be able to shift smooth again)

I cant sort if its Silo, my mouse/keyboard or what. Things I have tried: Installing a backed up copy of silo I had on my old machine - its doing it too. I know Z works fine (shift plus click smooths, not adds noise) It only seems to affect silo. And moreover, Ive tried tweaking the mouse controls in silo… but that doesnt seem to affect the displacement brush at all. I have no tried changing the keyboard shortcuts, but mostly coz I have my doubts it will help, and I never did it on my old system either (so cant sort why it would be diff there) Sooo… Im at a total loss on how I can swap it back so shift and mouse makes it smooth again.

Does it work that way for anyone else? Or maybe my old system was the oddball?

Anyone have any ideas how I can fix it?


I didn’t have any issues with it the few times I used those tools. But if changing the keyboard shortcuts do not work I wouldn’t know where to begin to look for a fix.


I have the same problem and still i can’t find the solution.
In Silo v2.2 (32 bit) still works fine, but since v2.3 (64 bit) and later versions i started to notice this issue or bug.


Looks like a bug but as a workaround the hotkeys for the brushes are sticky, so you can hold S to smooth and release S will revert to previous state.


Thanks Cinnsealach, i didn’t know that feature. Works great.


Hi all,

Thanks for sharing this! We played with the tool and found the same thing here, so we are looking into what’s causing it and will squash this bug soon.

Also, thanks Cinnsealach–your suggestion with sticky keys is a great workaround for now.



Hey awesome, thanks for the heads up. That should help a lot

And thanks to Presque too, for confirming its a bug! I thot it was just me somehow lol Glad to know it will be fixed.
BTW I am so glad to see Silo getting some love lately. I love my silo

Sorry Im so late with replies to this. I was just cruising the forum today, and saw it


hi all, i am having problems in exporting STL files in silo 2.5.4
any help? anyone experiencing same issue?
please help its important