Transfer Attributes isn't Working as Intended. HELP


So I’m modeling and unwrapping a tank that has a lot of repeating components on it (like hinges and flaps and stuff), and i figured the best way to save time unwrapping was to use the transfer attributes option under the mesh menu.

In the images I am posting you will see a set of two low-poly hinges. I’ve unwrapped the one of the right.

The hinges have the exact same topology as each other since I simply duplicated one from the other. It should also be noted that the hinges are angled.

Until this point the hinges were combined, along with the rest of the tank, into one object. Before I used transfer attributes I separated the hinges from the tank into two separate objects. I deleted the history, froze transformations and centered the pivots. However, when I used transfer attributes to copy the UVs from the right hinge onto the left hinge, things did not go as expected.

As you can see, the left hinge has been unwrapped but it now has a very big problem. The UVs for each face appear to be stretched and are facing different directions. I have no idea what would cause this. Before I started unwrapping I cleaned up the model, there have been no problems up until this point. Please, if anyone can tell me what I did wrong that would be great.


Try on a fresh scene with a new object and let us know if worked there.


Just tried it in a different scene with new objects and it worked perfectly. Something else I forgot to mention is that after I do the transfer attributes on the hinges maya will start telling me that the object has non-manifold geometry even though it was clean before the transfer.


Many works fine every time, what u can try is export the mesh obj and bring it back.




Tried exporting as an OBJ and importing it back in. Didn’t work.