The Foundry MODO: Time Travel Challenge - Support Thread


Can we post our images ALSO on the Foundry forum to get some more feedback? Thats always of great help.


I know it says up to 30 sec for the TV ad but is there a preference? Would it be preferable to be 30 sec?


Hello, to really hone the idea it would be great to have more product information…currently all we have to go on is a vague time travel theme. How can we create a commercial to sell a software using a generic theme? I am fine with that but the creative process would have much more direction if we had at least a little information on what the product actually did…even vaguely…is it a review tool? artist tool. pipeline tool etc. is there a log or tag line that conveys what this software will mean to a production or workflow?



I posted a WIP to the forum here, but the images keep disappearing from my posts. They reside on my server and should display properly, they did when I posted them. Are we not allowed to post WIP’s or something? I saw no mention of that on the rules. Or is it a forum error?

Edit: Sorry, just found the answer in the FAQ’s. Taking down from my server now. I didn’t see that previously.


If you think your message can be delivered in less time, then go for it :slight_smile: it won’t effect your chance at winning.


We’ve kept it fairly vague so not to limit creativity.

“You have exclusive knowledge of how this new invention works, what it looks like and what it’s capable of.”

It doesn’t need to be a software, it can be a machine, a type of transport, something you take, something you wear. Whatever really! It just needs to be able to take a person back and forward through time. Maybe check the WIP so far and see what others are up to?


Any ideas on why when I go to the Challenge, click on “view all submitted entries”, and select an entry, it comes up all mangled and pushed off screen to the right?

I’m using Firefox on Win 7 64. I’m running Adblock Plus and No Script, but have the Cg Society domain whitelisted for both (as you can see by the ad up there). Disabling them altogether makes no difference. When I summon up Internet Explorer from the depths of whatever corner of my drive it gathers dust in, I don’t have the problem. I’m happy to accept it’s an issue with my Firefox installation, I’d just like some ideas on how to fix it because it’s making it difficult to follow the Challenge.


Hi Spyndel, I’m not seeing this error. Is it happening only for video entries? I’d suggest you try clearing Firefox’s cache.


No, it happens for any entry when clicking on a thumbnail under the “View all submitted entries” link. Cache clear changes nothing.

I’ve completely disabled all the plug-ins I have running in the add-ons menu, and even disabled my antivirus for any web related functions it might have, and I still get the error. The only thing I can think of is that it has something to do with the custom text size I have set in windows. A while back FF changed the way it handled font sizes to default to the windows setting, which caused display problems on the occasional site. Haven’t had any problems with it in a while though.

I’m not messing with any of that though. I guess I’ll just have to use a different browser for the purpose of this challenge. Thanks for checking.


Ah, I fixed it. I went into about:Config in FF, and saw that I had a number of custom settings I put in place to combat FF’s poor font handling changes from a while back. I switched all these back to default, chiefly the minimum font size which I had set at 13 ( I suspect that was the culprit) back to zero, and it works fine now.

Of course, now FFs font sizing is awful again, but I’ll get used to it. Might be helpful for future reference.


Aha! that’s it, I shrunk my text and got the same issue… I’m pretty sure i’ve fixed it, please try again now. You might have to do a hard refresh to get the CSS to update. :thumbsup: :buttrock:


Thanks Keenly! Be sure to check up a post above where I ninja’d in a second response as to how I solved the problem.


Your way is better though, because it let’s me put my custom settings back in place. Thanks for the help!


Another question. The FAQ states that we can have multiple entries. For instance, I was thinking of doing a print ad AND a separate, completely different product design entry.

There doesn’t actually seem to be any mechanism for establishing multiple entries, though. Once you are entered, you can only upload to the existing entry which supports a single category. Is there any way to have a second entry outside of creating an entirely different CGS account?

Thanks for any help!


To add toSpyndel´s question, I´m working on an video ad and naturally that encompasses material for print and the product design.

So, is it OK to sort of synchronize the entries? My idea is to have 2 print ads support the video ad.


I would like to first design my Time Machine and enter it into the product design category, and then make an advertisement.

How do I go about entering 2 categories, I only have the option to select 1?



To be clear, I wasn’t talking about entering the same model in different categories, but a completely different model/concept in either.

For that matter, though, the question is the same even if someone wanted to do 2 different Print ads for different products.


@Spyndel, @CB_3D, & @Mackin By popular demand I have created a ‘Multiple Categories’ category for if you want to enter in more than category.

At the end of the competition if someone has created a winning entry but entered in the wrong category, we’ll move it if necessary.


You rock, Keenly!


The FAQ says the duration of an advertisement entry is ~30 seconds. Just how much tolerance is there either side of 30 seconds?

My animatic is currently running to 40 seconds, would this be too long?



Is it possible to know which font The foundry use?