Textures don't work on V-Ray Volumes


#1

Hey guys,

So I’ve been stressing over this for at-least a day now before asking, tried absolutely everything I could think of…
But the simple fact is that I cannot get textures to work on V-Ray Environment Fog.

My process:
1cm Cube
VRayMtl assigned
Opacity Map to 0
VRayEnvironmentFog into Volume Material

At this point, Volumes work perfectly fine, and I have been experimenting with much larger scales too, yet assigning any texture to Density or Colour, almost ALL textures create the exact same flat result, which just looks a little darker than usual, but 100% identical no matter the texture, without any detail from it.
I ended up dropping it down to these 1cm tests in the end.

Now I’ve been testing every single 3D and 2D texture that Maya has to offer, even ones that I don’t understand yet. The way I’ve been doing this:

3D Placement nodes match size of Cube
UVs are Cube’s default
All textures I’ve modified to give the optimal contrast, in order to see any change

Results:
All textures (bar a couple, but I’ll get to those), bear the exact same results, an identical render, that just looks like a standard volume cube setup, with no texture on it. 3D and 2D textures the same.
Scale is definitely not the issue.
I’ve tried experimenting with all attributes, going back to defaults for each one, trying combinations, everything.

Now there are a few textures that do work for me, but they are mostly not useful ones.
Those are:
Leather
Wood
Marble
VRayDirt
VRayEdges
And PSD did give colour, and perhaps Density if I experiment a bit more with it, though it did not seem to, even though all other textures that didn’t work for Density, also did not work for Colour.

(in above order)

I’d been looking at the examples here: http://docs.chaosgroup.com/display/VRAY3MAYA/VRayEnvironmentFog

They just throw a checker on a volume’s density, on a plain cube, and it just works. For me, and a friend I know who also uses V-Ray, it simply does not.

One thing that page says is “In the following examples, the fog Color has been mapped with a texture. World XYZ mapping type was used for the textures.” - Does anybody know what that means? Is that a step I’m missing? I can’t find any other nodes that look like they could do any kind of texture placement, other than the standard 2D and 3D texture placement nodes.
And I couldn’t find any way to hook a 3D texture node into a 2D texture.
I must finally say… I am at a loss for what to do =/

I know I can try to use Leather as the base and throw Marble in, for making clouds, and I could do it with Fluids no problem, but I would really like to be able to get this to work. Is there something silly I’ve missed, or is the manual talking bs?

(V-Ray 3, Maya 2016 SP5)


#2

That’s a MAX term. I think it’s like a camera projection mapping, only it’s from top/front/side. Maybe a MAX user can confirm.

Maybe try do a camera projection and see what happen.


#3

Thanks Panupat. Glad that part’s explained, for some reason that’s what it says in the Maya documentation on the V-Ray site.
However, it doesn’t matter what shape my UVs are, and I did try projecting from the camera a few times… most of the textures that are supposed to work, simply don’t =/

Can anybody else confirm if this either does or does not work for them?


#4

I know this is a two year old topic, but I wanted to say that I’m having the exact same problem. I’m trying to learn Vray at work and am pretty frustrated that this doesn’t seem to work. I’ve been googling around to see if anyone else reported the same problem and so far this is the only support topic I’ve found about it.

The ChaosGroup documentation seeks to have just been copied from their 3DS Max documentation with some terms changed, so now I’m wondering if it’s just broken in maya and nobody cares.