Texture Linking over Network keeps breaking


#1

Hi Guys,

I hope somebody can tell me what we do wrong.

We are trying to migrate from Blender to Cinema 4d at the company and we are hitting a wall when it comes to textures:
Cinema does seem to have some basic problems with textures linking on our network.
Even if the path name is right when we look at it through the Asset Inspector, Cinema shows a red cross. Relinking doesn’t work :frowning: We tried absolute and relative path names but for both ways cinema doesn’t recognize the file or it does for the active session but after a restart it shows up black again.

Through testing we found some strange solutions:

  • duplicate the texture folder and using the “new” textures works
  • even duplicating just the texture and using this copy works
  • copying to a local drive works

Both network “solutions” still seem to break randomly

But working completly locally doesn’t make sense to us. All of our Artist would need to have a local copy of our big! product database and keeping that synchronized with all the other artist. Thats what a network drive ist for, right?

Can somebody point us the way forward?

One of our artist suggested that the Server is messing with the metadata while creating a backups and this keeps breaking the linking? Sounds a bit far-fetched to me. I mean the texture file is working fine in every other program even after a backup.

Thank you
Alex


#2

For what it’s worth I didn’t have problem with old texture manager up until R20. It was actually a wonderful tool.

But it looks like the new and “improved” asset manager from R21 on isn’t as reliable, so maybe that’s linked.

On a side note, did you set appropriate file paths in the “preference” menu?


#3

Thank youfor your answer!
Yeah we tried setting up the appropiate file paths in the menu. Still the links randomly breaks, even if we didn’t do anything to the texture files. Cinema just won’r read the files.

But our thinking was/is: If we set up absolute file names, Cinema shouldn’t really care about those settings?


#4

At work, I have a network-folder mapped to a local Drive letter (“Z:\Folder”, on Windows obviously), and that works 100% reliable for years.

Maybe give that a try?


#5

Try your network firewall settings and setting exceptions for Cinema


#6

Thank you all, for the suggestions!
@keppn we have that setup

The one soution which works (at least for now) and can reproduced: we move the texture/image/cache files from our network to a local destination and than back into the network folder. Suddenly everything works. Cinema doesn’t display just a black texture. Very very strange behavior,

Now we just have to do that for all the products :frowning: But at least it seems to work.

Thank you all!