Team Render inconsistency.


#1

I have a pretty basic setup since I only have 2 computers with me, a mac and a pc, when I set up the team render everything starts out fine, both machines are recheable verified and thus connected, the team render starts and both machines turn orange which is the correct thing, but this only happens after a while when one of the machines turns gray, here is an image to demonstrate, http://i.imgur.com/UWexVTB.jpg

After this happens I have to go to the inactive machine and double click it so that it reconnects and gets going again with the team render, this however is highly inconvinient since one cant leave out overnight renders Id have to wake up every hour and check if everything is fine, I do have to say though that once you reconnect the thing seems to maintain and not disconnect again till the end of the rendering process.

What could be the problem, I have shut down in the settings the P2P Asset distribution and the Exclude Client on Rendering Error, I did this following the instructions on a previous forum from a person with a similar problem as mine still however it didnt fully solve it.

Could it be that team render still needs some polishing being new and all, or is there a problem with my setup.

I await your answers.

Cheers!!


#2

Ok about that thing of reconnecting and not having to reconnect again I take that back, I just had to reconnect again twice and now its not connecting anymore one machine is orange the other is green meaning only one is working.

Team Render does not do well with long projects like days render projects, I have to be doing something wrong Im guessing.


#3

understatement of the year.

sorry, there are so many strange things that happen with TR, feedback is non-existent to vague, very difficult to troubleshoot.

my first thoughts were with OSX (mavericks) there is a nap mode - apps will essentially go to sleep to conserve power - this could be it - so GET INFO on the C4D R15 Icon

now turn ON the checkmark for PREVENT APP NAP

maybe that will help solve it for you.

the only other thought i have is if this is using wi-fi (being a laptop i am assuming yes) that maybe it is putting that connection to sleep or dropping off from interference or something.

first though, check the app nap…

dann


#4

Thanks a lot man you were correct, there is an ption in the get info that says prevent app nap and it was unchecked for me, I will do a long render and post back here, though Im pretty sure it will work this time.

Thanks Dann!!


#5

Just wanted to post to say that what Dann suggested totally worked, so if you are running on Mavericks go check the prevent app nap thing.

cheers!!


#6

good news! :beer:

dann


#7

Do you run the latest version? In SP2 (R15.057) there was a fix for this (and for a lot of other stuff).

Cheers, donelgreeko


#8

Unfortunately our studio is still running Snow Leopard (as are most studios in NYC), so the App Nap isn’t an option for us. We continue to have connectivity issues even though IT, out of sheer frustration with Maxon’s tech support, reconfigured the network so we were all on the same line, assigned static IP’s to every machine on our floor and set up every station by manually adding the numerous Team Render Machines to avoid using Bonjour. This works for a while but then a day later you will set something off to render and then notice that a couple machines aren’t available, or are just sitting idle and I have to delete them, then add them again with the manual IP and security token. Then I have to pray that they actually pick up the job in the queue and work. Such a pain in the ass for such an unstable workflow. Truly mindboggling that Maxon released this in it’s current form, even with the update improvements.

So, again, I fall back on NetRender whenever I can and it works flawlessly, as usual.


#9

Interesting to see this thread brought back up, yea what Dann suggested worked fo a while, but sometime later I found myself in the same situation as Jack here, it all starts well and after a while some machine goes off and stays idle then you have to go back and add it manually and so on, you just dont know what could happen, you cant leave things over night working you have to come around every 2 hours or less to check how its doing.

Defenetly Team Render was not ready for release.


#10

i agree, i HADto run a couple jobs with Render Queue because of R15 - i can’t believe ANYBODY ever used that RQ before - i barely could tell what was going on, other then the progress bar which seems more ornamental then anything. what frame was running, what frame was running on what client etc… it was terrible, clients drop off for no idea why, to have a client join after is a crap shoot. can’t add in any that failed to connect at the start (which happens it seems if you have more then a few clients) then the whole send out the same frame a bunch of times “just in case”, at the end was pointless and wasteful… took so much longer then it should have using Render Queue. just no idea how any professional type user could operate with that as the solution.

i still feel bad/irritated that i was demonized too just trying to point out what seemed so painfully obvious as to the issues and mistakes when TR first announced… like shoot the messenger.

but seems i was proven right as i hear it from many about TR and R15 now, i know a few users that left C4D due to R15 just felt so disillusioned by maxon, (pro users mind you) and most all others just stayed with R14… i sure hope my next MSA payment will be worth it as i see it as 2x cost now since little of value came from R15.

fingers crossed. since no news at NAB i suppose it will be 6 more months or so until siggraph to hope for something.

dann


#11

At this point all I can say is thank goodness you were willing to go through and post all your numerous tests and configurations. It helped us tremendously, even though in the end (and despite the update) we are still stuck with a highly unreliable render solution that Maxon should frankly be ashamed of.

I think what I would like most to hear from Maxon is an apology, and an admission that they failed their professional users spectacularly with TeamRender. We still love Maxon, don’t get me wrong, but they really should have worked on this for another cycle instead of taking all of us for a test drive.


#12

We still have unreliable Team Render in R17, R18 and R19 - that makes it absolutely unusable for professional production.


#13

I gave up on TR a couple of years ago.

There are a few big gotchas when working with C4D:
Teamrender issues, Bodypaint neglected for years (and is very clunky), no decent UV tools…These are all sore points for me, and I’ve moved to other solutions for all of them.

For Teamrender, I replaced it with something a little different. Instead of finding another network rendering solution, I switched to Redshift which renders much faster on most of my work with a single machine using a single 1070 card.