Symmetry object in conjunction with normal / displacement maps


Hair and brow projection issues have proven more problematic than expected Nearly worked out now, except for the character left (your right) brow.

Trying to just use symmetric reflection of the other (character right) brow.

Brow is low poly, but using 4x normal and displacementt maps which look fine on original brow, but as you can see, look all wrong on reflected one.

In pic, I’m using object mode for the maps. I thought that might be the problem, so tried tangent, but not getting correct shading at all on either with that.

Is there some trick to allowing normal / displacement maps to behave correctly when the object has x inverted, or is mirrored via sym object? I could always just create separate flipped map, but point here is to minimize the setup, number of maps used, etc.

Creating both brows and combining into single map may be problematic due to the way they are created (and would cut map resolution in half… so hoping there is a way to resolve map reflection issue.


if you inverted X, your polys will have inverted normals, you need to flip those. then everything should look fine.


Hmmm… somehow still missing how it all pans out. Flipping one flips the other if using same material, so assuming I need to duplicate material.

So… if I duplicate material, flip x in normals on flipped one… it looks right in vp, but way off in render. thought it might be issue of UV map needing to be flipped to match normals or something, but haven’t got it working.

brow (25.8 MB)

Above images and proj have character L brow created by duplicating and flipping the R brow, then replacing material with duplicate with x flipped in normal tab.


hmm that’s weird… could have sworn i did that before… but i think it was with a tangent map, could be you get those issues because the normal map was baked in object space… maybe just mirror prior to baking?


Yeah. That works, but still 2 maps. I was just trying to see if I could do with one.

Not sure why baking as tangent map instead wasn’t working.

Baked separate maps so I can get moving, but interested in solution if it pops up.