switch IK-FK


#1

I made switch FK-IK. When switch on FK, hand drop and all created keys there were be lost. Need repeat for FK made earlier pose.

When I change in list exspression KeyFader on M(Motion), hand not drop. I can control bones from pose shown on curent picture. (pic.2)


I hold over tomorrow animation, hope what tomorrow with pleasure finish this work. In the morning opening this file and see, that in position,was can be seen from (pic.2) IK continue work, but FK dont work, although should be able to backwards.

Don`t know may be it dream or I save file in already change form? All able variant was taste. Please may be help me how work FK. Really need create pose in “zero” position, when pose already been create and need only correct her?

I should like to that after change slider on FK pose not change, this possibly?


#2

You should be able to create a key by hitting the Enter key, and select “use computed values” while in IK mode. Then turn off your IK slider, and animate as normal.

That should work, but if it doesn’t, you can turn off the IK slider, and key the FK to the same position as the IK pose on the next keyframe, then continue to animate.


#3

D`ont work,may be because not understand in english.Excuse me for importunity.I made so

10 frame:

  1. create motion,- move IK_Hand (the control ik-chain)
  2. create key for IK_Hand (hitting the Enter key)
    3)create key for slider IK_FK (hitting the Enter key)
    15 frame
  3. move slider IK_FK from IK position to FK(bones go to start position)
    5)???

#4

It should work. Please see attached screenshot.

It should be, 

10 frame:
  1) create motion,- move IK_Hand (the control ik-chain)

1b) Select a bone.
1c) Select “Hierarchy” in the Active Key Edit Menu (next to the dope sheet).
2) create key for bones (hitting the Enter key)
2b) Checkbox “Use Computed Values”!
3)create key for slider IK_FK (hitting the Enter key)
15 frame:
4) move slider IK_FK from IK position to FK (bones stay!)

Makes sense, yes?

[img]http://organzero.com/temp/ik_fk_switch_keying.jpg[/img]

#5

“Use Computed Values” checkbox makes “absolute” keyframe. Then you can turn expressions off, and the bones stay.


#6

isobarxx , Many,many thanks for You priceless help !!! You very clearly and understandable explain me decision this problem.Thank You very much!!!


#7

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.