Swimming Textures - how to stop?


#1

hello all,

I’m using a Maxon noise as a diffuse color and bump map… it seems as though the texture is swimming.

How does one stop this from happening?

I set the material UV space to spatial, but it does seem to work.

What’s a proper workflow when dealing with procedural textures?

Thanks for the time


#2

Do you have the animate texture checked ?


#3

Hi,

Animation speed is set to Zero… not sure if there’s somewhere else I should look…


#4

Can you show a file ?


#5

The noise needs to be set to UV space in the mateiral settings (as well as the texture tag applied to the object). Of course you also need your object to be properly UV’d too work


#6

if you happen to be using the native render engine (not redshift etc) you can get around this by adding a Stick Texture tag to the object. This tries to glue the procedural material to the deformed surface.


#7

Thank you!! Ok so it’s a process i take it… Is this overly complicated, or is it me…

I have to prep every model in order to pin the Noise to the mesh?

Thanks again for your time


#8

Its just part of the process. Always been this way no matter what 3d software package you use. Uvs are necessary if you animate deformation on a model using procedural shaders. Or else use stick texture tag.


#9

If you are using Redshift be sure the Projection Space Type in the Triplanar Node is not World but rather Object.


#10

Thank you guys for the help… it’s greatly appreciated. Yes, I am using Redshift btw… :grin:

Here’s the thing… I’ve baked this mesh to an Alembic file and then started applying the materials… Would this have an effect on how the Noise responds?

I guess the UV’s, or lack of… has been baked into the model and that’s what’s causing the swimming… regardless of object mode or world mode… the noise has nothing to stick to… ?

I will test it out, but I wanted to at least ask if my assumption is on the right track.

Thanks again!!


#11

You might enjoy this superb tutorial but you will definitely need a cup of coffee to make it to the end! At least check out minutes 3-8 on the Triplanar node.

You should be able to stick it down with the Triplanar despite lack of UVs
Projection Space Type
This specifies the projection space type, which determines which object shading coordinates are projected into uv coordinates. The options are as follows:
World - uses the world-space coordinates that are being shaded. This option will result in texture projection ‘swimming’ if the object moves or is instanced.
Object - uses the object-space coordinates that are being shaded. This option undoes the world transform to lock the coordinates to the local object space, resulting in no texture projection swimming when the object moves or is instanced.
Reference - uses the object reference pose coordinates, if available. This option results in no texture projection swimming when the object moves, is instanced or is deformed.


#12

Here is another tutorial which is superb and it shows a different way to pin your texture to the object:


#13

thank you for the help @teknow… I’ll have a look at this and post an update on my progress…

Thanks again!!!