substance painter problem


Hi guys im a bit confused. Ive modelled a game environment in Maya LT and in Unity its fine no culling issue and my normals are definately the right size.
When i bring the mesh i want to play around with textures for into substance painter though, it appears transparent in most parts which i find odd.

any ideas ? am i missing a setting in maya i need to check when fbx exporting or a setting in maya i need to do to my normals? is it something in painter? any help appreciated :slight_smile:

oh and it might have something to do with it being a duplicated mesh just not sure what ive done wrong, because its an environment and the other half is almost identical (until we set dress it) i thought the easiest thing to do would have been duplicate special. Perhaps i should have just duplicated it and rotated it? (it was grouped first). i just tested one object , used duplicate only and it was fine.
Does anyone know a way to fix it if you have this problem without having to delete and use duplicate and move the objects?


Looks like flipped normals. Turn off back face culling in Maya and you should see inverted faces. Unify the normals before export. Also, having done this, check for and fix flipped/inverted UVs.


Thanks for the reply :slight_smile: I found the normals are fine when i display them in maya though and in maya backface culling isn’t on (hense why in the first image you can see the faces no problem (the texture is black btw)). If i turn on backface culling you can see the difference however, and it becomes transparent in places. I know the normals look small in that image (look closely you can see the lines poking out) but thats maya LT, I’m working in meters and for some reason even if i put it to max display the normals line doesnt go out far.

I found this problem doesn’t happen with duplicate the mesh which is odd so was wondering if it is a setting in maya i have missed regarding fbx or when i use duplicate special? i used fbx 2014/2015 as the format.
Would be nice just to clarify that so i remember not to use duplicate special in future. Its not a big deal but good to know when im building modularly for my textures that i wont have a problem with the mesh not displaying correctly (though its oddly fine in unity, this only happens in substance or marmoset tb).


Try freezing your transforms (Modify -> Freeze Tranformations in Maya 2016).If any of your meshes have a negative scale value they will render transparent in Painter


this worked perfectly - thank you so much ! at first the flipped normals doesn’t show up … but when you freeze transformation, it will give you which mesh has this issue