Stop animated volume mesh from jiggiling


#1

Hi!

since ages I wonder how to stop an animated volume mesh from jiggiling. It´s an issue with any Volume mesher I found. While adapting the mesh to the new positions of it´s root content elements the mesher creates a mesh surface that is flickering constantly:

Does anyone know a way to reduce this without cranking up the voxel size close to 0?

Thanks!

Sascha


#2

Could you check the video ? for me it’s empty.


#3

It´s this link (Delete the space between : and // )

https: //drive.google.com/file/d/19UBhFOGCIMcyYBsAfeCe43AdPE2xPv9G/view?usp=sharing

The link works but the integration here is buggy…


#4

It’s normal to have jitter when the geometry is growing from the boundaries of the volume area (I assume this is a shader and not a polygonal derived mesh, but can also be present when using boolean operations with polygonal geometries in the volume builder).

For me a voxel size between 2-5 is in most times adequate.

If you can’t decrease the voxel size do the following:

  • Sometimes the scale of the object is too small, scale-up the object a bit (not the volume builder)
  • Add an SDF smooth Effect (can be slow but gives a good result and sometimes interesting effects)
  • Add a Smoothing Deformer with the Volume Mesher in a Null (much faster but can still have jitters)

Your animation is shaded like a cartoon and I can’t tell if it has a very low poly count, jittering is unavoidable if you use a low poly count. Also it is still jittering after it has been fully grown which makes me believe it’s moving through the voxel space instead the polygon space (if this is the case animate the Volume Mesher not the object nor the Volume Builder)


#5

Thanks for all the input!

I found a solution! It´s the highly expensive x-particles plugin with their newest XP Open VDB Mesher: https://insydium.ltd/support-home/video-manuals/x-particles-video-manual/generators/xpopenvdb/#1309

See the result:

https: //drive.google.com/file/d/1Da9gTbCImeX70gaKEU0UNuCI9K_KbJZA/view?usp=sharing

In the front it´s x-particles. In the back it´s the C4D Volume Mesher Setup. Both tweaked to the best possible with all types of smoothing and reshaping setting and a C4D smoothing deformer.

Plus: the xparticle mesher renders 3 times faster than the C4D one. But xparticles is nearly as expensive as c4d on it´s own… so … well…


#6

I don’t have X-particles and never used it. Purely by watching some of the videos you provided I have to assume that the X-particles particle emitter is optimized for better fluid simulations. That said I think that the emitters in x-particles do not emit in the same way as c4d ones.

The C4D emitters emit in a truly random way, on the other hand the x-particles are emitted from a discrete matrix. That means that there is a constant flow of particles on the same trail. That’s why there isn’t much disturbance in the X-particle mesher.

To achieve a similar effect in C4D create a particle emitter and set it to have one short burst of particles. Then put it under a Tracer and that under the Volume Builder and Mesher. That will give you a smooth flow but don’t try to disturb the flow with forces after it has been set, it won’t work like a fluid. (You could try having more bursts of particles and shorter spline trails, that could work more naturally)


#7

Both setups are made with the same set of growing splines. No particles involved at that state. But you interpretation is probably correct in terms of the c4d volume builder. it is just not optimised for animated source elements.


#8

And about having a simple spline: Just try it yourself. put a spline into a c4d mesher setup and scale the spline. you´ll see that that the complete mesh is constantly updating completly. it is not working with any “continuity feature” …


#9

Its perfectly possible to create smoothly animated meshed volumes with C4D’s native tools, so I’m not sure what’s happening for you here…

  • Have you experimented with the settings in the Volume Builder object? Voxel size/ Radius? Density?

  • Are you using an SDF smoothing layer?

  • Have you tried using a mospline object to grow the spline, rather than using a spline directly? This will allow you to organically grow the spline from nothing to its full length…

  • Have you experimented with the spline settings (e.g. intermediate points set to uniform…)

C4D’s volume mesh and X-Particles OpenVDB Mesher are actually based on the same code, so I’ve found them very equivalent in their output…


#10

Yep, tried everything you mentioned. Don´t get me wrong, I would love to be convinced that it works! Is there anyone who can send me an animated spline or moving particle based growing mesh where the mesh does not make noticable changes all over the place, build with c4d volume builder and mesher, please do so.


#11

Here you go…

spline_test.c4d (210.6 KB)


#12

Wow! Thanks man! That was the hint I needed! Here is what your setup did tell me about the issue:

  • My splines where too small (0.001 cm) so I couldn´t get the settings right

  • În my mospline setup test I did just use the mospline and adjusted the width settings which is even in your setup producing a slight jiggeling. So the final trick was to through the mospline in a cloner with one clone and voila no jiggeling!

So never lose faith in C4D :wink: