Some objects falling through collider


#1

Hi there,

I have been trying to solve a problem in my animation where some of spheres fall through a moving collider body no matter what. I am only at the start of this project and I am srsly stuck. I tried various settings with steps per frame (doesn’t really help and messes up gravity), collision shapes, geometry density, scaling up all objects, etc., but nothing really seems to be working.

Project file: DELETEMEhttpsDELETEME://file.DELETEMElu/d/pwJ it doesn’t allow me to post a link just delete “DELETEME”.

Any help would be greatly appreciated!


#2

Have you used the collision shape debug view to check the collision shapes are what you think they are?

Is this issue caused by order of operations? How is your object manager laid out?

You’ve increased the solver steps (not steps per frame) and reduced the error margin? I can’t remember what else is in the ‘Expert’ tab of the dynamics settings. Worth playing around in there.


#3

Thanks for reply! Yep, I tried all of them but they didn’t make much of a difference. I posted a link for the project file, here are some printscreens to see the dynamic meshes and the object order:


I accidentally put everything under the Fields null, but that isn’t the problem.


#4

Thanks for providing comprehensive screen shots, if more people did this it would make helping a lot easier.

As I see it the movement of the deforming track is to great to be ‘noticed’ by the collision detection. With that much movement from frame to frame and due to the fact the track is very thin without a huge increase in solver steps the dynamics will never be reliable.

In this circumstance I would create a non-rendering collider which is much thicker. Forget trying to collide with the thin tracks I doubt you have much success (unless the next tip helps).

As a quick test try dragging the balls down to the bottom of the Object manager so that they are the last things calculated after the colliders have been deformed. I could be wrong but priority issues are still a thing in C4D.

I have used C4D for 15 years but stopped on R20 and looking at the new icons makes me weep. I can’t tell what they’re supposed to be. Maxon have lost their collective minds if they think these are an improvement. smh.

HTH


#5

Sorry for not getting back to you earlier. Glad the screenshots gave you more insight into my problem, and thanks for your help!

Yeah, there were some changes to the UI in R25 (I think). But once you get accustomed to it, it’s okay. Icons are different, but IMO look simpler and neat, and you can still change the position of the tabs as you see fit. Their new cloth simulation system is probably one of the best updates.

I tried to increase the thickness of the stripes, but that didn’t really affect it. Unfortunately, changing the hierarchy didn’t help either. As you said, the deformation happening to the collider was probably too fast and big, so I used a delay effector for the animation and tried to slow it down a bit. My current settings are 100 steps per frame and max. solver iterations is set to 100 as well, error threshold 1%, collision margin 0.1 cm. These things helped, but 10% of the spheres still fell through. So my final changes to make it work were changing the friction from 70-80% to 10%, both on collider and the rigid body + bounce not above 5-8%. That helped especially when the spheres were set to Moving mesh. Convex hull worked even without the last changes of the friction and bounce.

Now 99% of the spheres are not falling through (using a convex hull).

Thanks a lot for the help and explanation about the limits of the dynamics.


#6

Well I’m glad some advice was useful.

Even in Houdini, my main App, you have to learn the limitations of the dynamics solver and cheat where necessary with things like invisible colliders. I’ve even put invisible colliders in that are only there for 1 frame just to help with problematic dynamics. No one is ever the wiser and it can save hours of hair pulling.