Silo 2.5 Feedback


I’ll start this thread in order to provide feedback to the Nevercenter devs about modeling zen. Feel free to add:

  1. Error pop-ups - Offer the option to remove them or show them at the bottom of the interface (a la Maya). Use a color to draw attention to them as well.
  2. Rotation & Scale values - Don’t zero them out. Offer the option to freeze transformations if required. They’re absolutely unusable at their current state.



Love the organized thread for this. Thanks! We are watching it.

(will get some replies to feedback in here soon)


I have a feeling that when i alt+scroll to zoom, or alt+rmb the framerate is choppy. This does not happen with rotation or translation of the camera, where the fps is silky smooth. What do you guys think?


  1. No popups, and no color like user suggests to bring attention - simple gray text display in the left bottom corner like every other app notice msg.
  2. Bring back checkbox mark. Like you did it now checkboxes looks more ‘disabled’ than ‘enabled’


Error-pop up feels bad because it will stop my flow, my modeling Zen. I really would like to at least get option turn them off.
I feel like Silo is has been always trying to get modeling more fluid and fast by minimising every unnecessary click. But Pop-up error that I have to click OK is fighting against this philosophy UI Silo has had so far.


Nice thread Flaye


  1. When the scene editor is full, it auto scrolls back up to the top of the list whenever I select something; causing me to select other items in the list by accident.
  2. The cut tool causes vertex colors to turn black (already reported).

@outburner: I just checked, the framerate is good.

spec: gtx580, 3570k


Hi folks, been using Silo_2_5_02_Win_64 here and I have the same problems with mirroring geometry that I had with earlier versions (2.0). Everything is fine until I attempt to turn the symmetry off, which usually crashes the program. I don’t think the software has ever crashed on me except for symmetry that I am aware of. I am modeling a pair of boots for a Poser figure presently. I have one boot exactly how I want it, and I now need a left hand version for the other foot. I select the model and use modify - mirroring - mirror geometry and the boot disappears. I turn on the options and make sure I have the axis correct, then mirror it with the button in the options panel and it mirrors, but the two boots are one part. If I move something on one boot it affects the other one as well. Un-checking enable symmetry crashes the program. Anyways, I am excited for the updated new Silo, but I was hoping these problems I was having with symmetry would be a thing of the past. My machine is not state of the art, but not too shabby. Windoze 10 pro, AMD six core processor (Exact model can’t remember), 32 gig ram, GTX 1060 - 6 gig video card. Also, I just built this rig last December, and I had this problem on my old 'puter as well, and that one was a Intel machine. I just re-opened my boot model and turned symmetry off without it crashing. I was then able to split them into a pair without issue. I thought maybe I had an instance somehow before but I got a message saying I needed to select a instance, so that was not the problem either. I really want to say something positive here, been using Silo for quite a few years, and I really do love it. The symmetry thing always kind of makes me cringe, but I always save my work before I attempt it, and I always accomplish what I set out to do.



I installed Silo 2.5.02 and accidently said “NO” to the new UI option that pops up at start up. How can I force the pop up again to choose the new UI over the old one?

Thank you very much


I would have thought trashing silodata.sip would give you the option to choose again, so I tried it (backed up the current file of course).

The option to choose interfaces does appear upon starting Silo, but I ended up with an inoperable interface. No right click menus etc. It seems that Silo is creating an incomplete silodata.sip with half of the UI functions missing. I though it just made a copy of default_silodata but the generated file is half the size.

At the end of silodata.sip is

<prefgrp name=“Other Options” id=“100149”>
<item type=“bool” name=“2.4 Interface Updated” val=“1”></item>

I assume if you chose no, the value is 0? Though I tried setting mine to 0 and did not notice anything different…


Regarding the error pop-ups…

Maybe you can just add a “don’t show this again button” which is common across many apps. Then those of us that don’t want them only ever see them once.


Interface buttons.

How about adding the ability to ctrl click/right click or whatever on buttons to bring up the opts for the functions that have them?


I can confirm this. I loaded a file with 900+ parts in it and found I could click on the lock/unlock button, the visability button or the object display mode button and it would not move. However, click on the name or the other object display mode button, and the whole list jumps right back up to the very top is a flash.


Solved it. I just went into my Documents folder under my user name, went to the Silo folder and in there, deleted the 2.5 folder. Restarted Silo and the option returned. Lost my customization on a few things but its ok.


Snapping Manipulator
This needs some attention I think.
When aligning to facess and edges, the manipulated object should align the selected axis towards the target face/edge centre. Currently it just takes on the targets normal vector. (I think this is a regression from 1.4 which I think functioned as described).

I noticed today that when aiming at faces with the alignment snapper that the manipulted geometry sometimes vanished.

The centre widget should snap to geometry, not free move. If you want to move without snapping just hold down w. It currently takes up to 3 moves to snap objects to a specific target. I’m sure what I am asking is how it worked in 1.4 but I could be mistaken, its been a while.

Duplicating Objects.
I’ve mentioned this a lot in the past. If I copy an object into the clipboard then move the object; when I paste it back it should appear at the orginal coords not where the source is now positioned!

Partial Subdivide
Bring it back, please…

More useful numeric editor
Don’t zero rotation, or please explain if there is a reason this is not currently possible - this has been a thing since v1 :]
Ability to do basic maths (current x-size+additional to make new x-size etc)

There’s more but I will leave it for now.


• Smoothing groups and hard / soft edge tools and control
(This is probably more of a feature request than some working feedback)

• I also second removing the error messages - any chance of putting them in a strip along the top or bottom, similar to alerts in Maya or Blender?


>Add in-Silo rendering with GPU/CPU for quick preview how mesh looks


Since they already have a RIB implementation I would like to see them expand on it so we can use Renderman with Silo


You could export to OBJ and import that into Daz Studio and use Iray for rendering.


>Make rotate ring a bit thicker or option to make it thicker, semi-transparent and custom color
>UVs need commands Select ring (s) > straighten, Select loop (s) >straighten, Copy/Paste Uvs
>Zbrush< >Silo bridge
> Internal render - I think it’s very simple now to add raw GPU render for AO preview
> Render AO maps
> Tool for creating polygons arong round objects ( like 3D Coat Stroke Tool)
>Tool for creating polygon stripes/pipes along spline
>Slice cut loop tool like in Zbrush - cut with line, spline and lasso


This has been happening to me as well. @iron-bear-xl or @mattymanx, have either of you found a solution or workaround yet?