Saved animation render frame does not match Vray Frame Buffer


#1

I have been dealing with this sort of thing for some time and I’ve seen a lot of forums about this but the solutions haven’t worked so far. Most posts are about this issue with more drastic differences as the result of 1.0 vs 2.2 gamma. I’m not sure that is my problem. I have 2.2 set up everywhere I can. I have sRGB on VFB and Photoshop is sRGB. In my situation the difference is not drastic but still matters.

What I want to do is find a way to have the .png (or otherwise) frames of my animation save looking exactly like the Vray Frame Buffer.

I created an animated gif to show the exact difference. You can see the hazy different look in the image on the left and the levels on the right. The darks are getting distorted.

Any clue on why the saved image gets washed out would be greatly appriciated.

3dsMax 2018. Vray 3.
Thanks!

Preferences are 2.2 Enabled. Affect Color Selectors / Affect Material Editor.
Max Script Listener -> fileOutGamma=2.2 (this seemed to help it only a little bit)
Color Mapping -> Reinhard Gamma 2.2. Mult 1. Burn 1. Collor Mapping only. (basically defaults)
VFB sRGB on. Actually, everything is default. I don’t touch anything in the VFB.

vfbvspng


#2

Interestingly If I save out a PNG from the VFB as Automatic the image is darker than the VFB image (By FVB image I mean Copy to Clip Board and past in Photoshop, which is the desired look I want).
And if I save out a PNG from the VFB as Override 2.2 the image matches the render frame pngs. (washed/brighter)

Perhaps this info helps in tracking down the issue.


#3

it seems some your corrections control are checked , check them by click the 1st button bottom VFB


#4

The Globals correction controls? I never touch those. So something by default is changing it.

Do you know what it could be?
When I look through them they all look pretty straight forward and all checked off. I dont really know exactly what I’m looking at. But overall it just looks default and off.

This was a new ground-up file. I’ve had these issues for a very long time with other projects. And I don’t really mess with settings too much. I keep defaults.

So My question would be.

  1. How would I get that to not have an affect?
    or
  2. Is it possible to get 3dsmax output to match VFB adjustments?

The histograms on the render output png seem bad to me. Like the bottom looks clamped off. Clipped. Like if I made the entire scene pitch black with no lights it would come out dark grey in the output but black in VFB.

Edit: This issue has boggled me for ages. I have read so many forums and tried so many things. And the render output is washed out compared to the VFB. I usually end up giving up and doing some levels adjustments and tweaks in Photoshop but in this case i’m rendering a lot of frames. I’d prefer to not adjust every one by hand if I don’t have to. Plus i’d really like to know whats going on (so i understand) and make future projects more sound.

I tried exposure control Physical Camera to see if it would make them match but didn’t work. I normally had no exposure control in the enviro panel.


#5

maybe you should upload your file and output image to find it
I know muti-gamma may seems like this


#6

agree with AEI, put a simple color texture on a box with your basic setup, upload the file (2019 or earlier if you can). We can check it out. Sounds like something minor in your setup that needs adjusting.