Real Flow and 3dsmax.....wont render mesh


I am using realflow 4, with max 2009. I had been using this for awhile and everything worked just fine. Do my simulation in realflow, then import mesh into max.

Just recently, I import my mesh. Press render and the realflow mesh wont animate? it just sticks to the same mesh frame, and keeps rendering that one frame. After some trouble shooting, i found that it will animate if im in scan line jsut fine. But for some reason when i go into mental ray, the mesh wont animate?? anyone else have a similar problem? did i accidentally hit some setting in max?

I am currently reinstalling everything because I cant seem to find the problem.

Real Flow and 3dsmax…..wont render mesh _solved

This sounds like a validity interval issue - I have seen the RealFlow mesh loader doing this, and I have seen mental ray doing this with other kinds of objects, but I don’t have a precise solution, just some things you could try.

The idea is the following: Every object in Max (be it a primitive, a modifier, a material, a helper, a light etc.) defines something called a validity interval. It basically describes to Max for how long the respective object can be considered valid without the need for an update. This system allows Max to be “lazy” in updating object if they are not changing. For example, if you create a Box primitive that is not animated in any way, its validity is set to “Forever”. If you keyframe its Height from frame 0 to frame 100 to change from 100 to 200, the validity interval will be collapsed to return the current time only within the range from 0 to 100, but would be valid before frame 0 and after frame 100 if Out Of Range types for the Height are set to keep the value constant (which is the default). So asking for the mesh to display or render outside of the interval from 0 to 100 would return the last known mesh and be faster. As mentioned, this applies to EVERY object in Max, and when you combine such objects, for example have a Box primitive with a Bend modifier and an animated material, the validity interval of the scene object becomes a combination of the validity intervals of all participating components. This usually leads to the object being force-refreshed on each time change.

So when a 3rd party object starts misbehaving because it doesn’t tell the renderer that it must be updated on each frame, you might get an animation stuck on the last frame that got updated. A possible way to break the validity is to add a modifier (e.g Bend) to the modifier stack and set a key on the first frame with a value of 0 and another key on the last frame (or far far away in time, does not matter) also with 0. Although the Bend is not bending, its validity interval is collapsed to current time only because Max sees a keyframed track in it and assumes it needs to update the whole stack. If the validity interval is indeed the reason for the RealFlow mesher to not update, this should make it work again in mental ray.

If the cause is something else, then this would have no effect. In that case, let us (and Next Limt!) know that it is not working…


theres a button in the mesh importer to animate mesh i think. inside 3ds max


Thanks you guys for the reply:

Bobo: I placed a bend modifer and keyframed it. I even put a .001 on the end keyframe just for a test. Still not working? Renders two frames, on the second, it sticks and the fluid mesh wont update, or render its animation. In the viewport it works just fine, the mesh is changing. If i render still frames, mesh renders just fine. The minute i try to render a sequence it sticks after about two frames?

I looked online and found a few people with the same problem, but nobody seems to have posted a solution?

This is really frustrating because after about 2 weeks of doing awesome animations, at the very end this just pops up out of nowhere? There were no problems rendering the meshes before? really strange?


I am jumping up for joy right now guys. I have a solution:

After giving up and trying to setup a scanline render, being very disapointed I re opened my old file and tried one last thing. I had forgotten I originally rendered out .rpf’s because I was hoping to put motion blur on. I went back and changed my .pngs to rpfs and now the realflow mesh is working! Its a bit of a workaround, but it actually works.

I scoured the internet for the solution and the best info was bobos advice. Thats it! So if anyone else has the same problem hopefully they find this thread.


This is quite spooky. Do you have any extra channels in the RPF? Like Velocity etc.?
One way or another, be sure to report this to Next Limit. It is their problem in the end.


Yes, I just have velocity and zdepth checked. I will be sending this to them by the end of the week. Thanks again for your reply, it steered me on a path to understanding what was going on…sort of. :smiley:


This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.