R20 Picture viewer at 'half size' washes out


#1

This problem (or limitation) was present in earlier versions of C4D, and I was hoping it was addressed with R20. It appears to switch color profiles when viewed at anything other than ‘full size’.

I’m doing a 4k animation currently, and want to preview it along the way. I want to set the resolution (in the playback settings) to ‘half size’. However, unless it is viewed at ‘full size’, it looks really washed out and not a good representation of what was rendered.

Is there a work-around for this? I tried searching, but if I’m being honest, the CGSociety search tools are pretty finnicky with this new forum software. I’ve not found what I’m looking for.


#2

You don’t save any RAM by resizing the display in the PV, on the contrary. The original image is always in memory and having to display a reduced resolution image additionaly will cost more. It is not realy noticable though.
If you view an image at 50% four pixel will need to be displayed as one. That one pixel will get an average color of the original four, thus the display is less precise than it was and qickly looks washed out. This is neither a problem nor a limitation, it is just the result of an intended action, your action of reducing the size to display less information and that is what you get, less information.
Why not just display at 100% and be done with it? It does not cost any more memory or processing power and it shows optimal results.


#3

Hmmm…That has not been my experience at all.

I might have not explained well enough. I’m talking about the pull down menu on the right. I set it to “half”. It DOES save ram. I’m on a limited ram machine at the moment (16 GB) so when I’m working with 4k and sometimes even 1080 I have to use that setting to allow me to see more of the frames on playback.

I understand what you are saying about 4 pixels into 1, but I’m also not sure why that would be the case. It looks DRASTICALLY different. And if that were the reality, then why don’t After Effects, Premiere, Photoshop and any other imaging app for that matter suffer from this?


#4

And actually I did say it correctly…probably just not clear enough. I’m changing the resolution to half and view size to 50%. I realize the 50% doesn’t help, but the “half” sure does.

So if I have a rendered frame, and only change the view size to 50%, I understand that wouldn’t save me any RAM. The only real reason to do that is if I’m working in very high resolutions 4k+ and want to see it all on-screen. Doing that also doesn’t change the colors at all. Nor should it.

But that’s not what I’m talking about. I’m talking about the playback setting on the far right which lets you choose “full size” “half size” “third size” or “quarter size”. This absolutely saves ram if you don’t have much to work with because I can see that it clears out all the [green] cached frames and it re-caches based on the new size.

So that is the “why” as to me using that setting. My “why” remains…why is it so washed out?


#5

Here’s an example set to “full size”.

And here is the exact same frame set to “half size”

Half the size (1/4 as many pixels) should not mean a complete shift in color.

I bet if I render a solid color and do the same thing it will also look washed out. That would defeat the theory of 4 into 1 pixels on resizing.

This issue has been present for several versions of C4D. Perhaps it is not seen as an issue, but I believe it is. If you take a 20 square pixel sample from the bottom right corner of my top image (the full size version) and reduce it 50%…even though it has to sample 4 pixels and squish into one… I believe it would be the same general color which is not the result I’m getting.

EDIT ok so as I suspected, even using a solid color (which has no various shades to sample from on down-sizing) exhibits this issue. I’m officially calling it that now until I can be taught that it’s just a setting or something I missed! ha

Solid blue color at full resolution in PV. (view size on left menu is 100%, view resolution in playback settings is 'full) I’ve included the histogram also, because it actually is different depending on resolution.

Same solid blue color at half resolution in PV. (View size on left menu is 100%, view resolution in playback settings is ‘half’) Notice how different the color is, even though there are no other colors for it to average from. And notice how different the histogram is.


#6

Yes, if you choose half size for the cached preview it will need less memory.
I’m unable to confirm your problem with the change in color display though, that might be something related to your actual scene and render settings.
Please send a scene and description that shows the problem to Maxon support.


#7

It’s all about messed Gama … Make sure to setup your Image Color Profile to sRGB in Render settings / Save section … also in PV you can use “Display the Color Profile in the Picture Viewer”-button to switch b/w linear / nonlinear…:wink:


#8

@srek - this is not scene specific. It seems to do it on every PV render I’ve done. I will try a few more things before sending a file to tech support, so I can at least narrow it down more. Perhaps it is the type of file I’m rendering to, or something like that.

@ugrens - Color Profile in render settings is set to sRGB already, and the picture viewer already has checked on “show color profile”. (if that is what you meant)

I just tried reloading an image sequence that was showing this behavior yesterday while it was being rendered. It does not do it now that the rendering is complete. Also I noticed that my saved files are displaying in 8 bit whereas if I view them during rendering (and after each frame is rendered within one session) they are displayed as 32 bit. This makes me wonder if it is caching them to b3d or something during the render session, but then once they are saved and reloaded later it is loading them in the file format as they were rendered. Perhaps this has something to do with it?

Regardless, it is an unexpected behavior and I hope to help get to the bottom of it and get it changed.