R20 High DPI 4k screen


#1

Is anyone using R20 on a 4K screen. In R19 under windows compatibility options, I’d choose “Override scaling …” and then increase my font size and the program would be sharp and usuable (except some minor quirks).
In R20, the node editor seems to become broken using this method (the mouse is not in the correct place, and it’s for example impossible to click on the node ports and drag wires).

Alternatively, if I use the default windows scaling, the program becomes obviously blurry.

Is this buggy behaviour, or is it just me? Pity that we still don’t see proper hdpi behaviour in 2018, R20.

Edit: here’s what I mean
Edit2: this does not happen with the Xpresso editor, only in the new Material node editor.


#2

Don’t use this Windows “override” option - it’s known to not work reliable - esp. in cases like in R20 where parts of the app work with HiDpi support (the node editor already supports HiDpi).

If you want to change the scaling then change it in the display settings of Windows 10 (which even supports individual settings for different screens).

Best regards,

Wilfried


#3

Cheers Wilfried,
I guess you mean this?

Setting it back to 100% ? But that will screw up many of my other apps (which will look miniscule)


#4

Yes change the scaling only there (to the size you want) and don’t use the “Override” dialog.

Best regards,

Wilfried


#5

But then everything looks blurry in the C4D interface.


#6

That 's how it is supposed to look on Windows in an app (or parts of an app) that don’t have HiDpi support - and why it looks different in the node editor (which has HiDpi support).

Best regards,

Wilfried


#7

Welcome to the delusional world of “4K”


#8

I have a 4k Monitor for 3 years now at work. And because the viewing distance is 60 cm and the screen is 34", you see the difference, believe me.
And every other app is usable and optimized for this resolution. Even C4D was usable before they made 5% of the software ready for HiDpi and the other 95% blurry.
What am I supposed to do now? Use R19 until everything is optimized for HiDpi, perhaps in R23?
Tech support told me that they are working on a solution. But what Wilfried said made me a bit sceptical if there will be one.


#9

Hi Wilfried,

I tested a bit:

Windows 100%

  • C4D sharp but interface supertiny
  • Node Editor sharp but interface supertiny

Windows 100%, Interface Fonts 18 instead of 11

  • Node Editor font too big and not readable any more

Windows 150%:

  • C4D blurry
  • Node Editor blurry

So how is the node editor optimized exactly?

Grüße
S


#10

Exactly. Feels a bit messy to be honest. Is there so few people using hdpi screens? We use them for years now. My personal laptop is 3k x 2k too, for quite some time.
Adobe software is hdpi ready for years now, Houdini is too.

For me now the solution now is the override option. Everything looks tiny, so I l increase font size. Kind of works, but lots of interface glitches and node editor problem. I’ll try to overcome it by using the attributes panes left and right of the node editor. Not as nice as using the nodes and wires but possible.


#11

@mt_sabo: I should have asked initially: Which Windows 10 version are you using? Are you using WIN10 version 1803 OS build 17134, or later?

Older Win10 version might deliver wrong offsets when doing D&D. on HiDPI (besides other HiDPI quirks).

Regarding what to use on HiDPI

  • As long as the Override option works as imperfect as it does: I’d suggest not to use it
  • You can either use 100% scaling and set a larger font (16 instead of 18 would be fitting)
  • or you use 150% screen scaling and try to counter the blurriness of the text with the OS “Advanced Settings” under “Fix scaling for app” - there is a “Let Windows try to fix apps so they are not blurry”

Best regards,

Wilfried


#12

Indeed, using 1703 (build 15063). I’ll try installing R20 on my laptop which has the latest Win10 (at the office I need to contact IT for an upgrade)

Regarding the 150% scaling and blurriness, obviously the problem is not the fonts looking blurry, but the viewport. I can live with blurry text and icons, but cannot work with a blurry viewport.
150% scaling

No scaling (override):


#13

There is no difference between Win 10 1803 and older versions.
The “Let Windows try to fix apps”-thing does not work either.


#14

I gave up trying to get things like this and AE plugins to display correct. Made a custom resolution of 2560x1440, waste of a 4K screen to be honest but needs must when the devil drives. Everything looks as it should. Not sure who is to blame here but is not changing anytime soon by the look of it.


#15

A large number of people use monitors in 4K. I bought such a monitor at 27 inches in order to have the same pixel density as on the retina of the MacBook. I also wrote here on the forum at the beginning of the year about the problems of the interface, but in fact they don’t care.
Maybe they will need another five years to fix this problem.:confused: