PyroFX Dry Ice


Hey Guys,

i rly hope that this is okay to ask.

First of all - i am using Houdini at school for the first time but never learned it before.

So i do have a Scene with a cameraprojection done in NukeX. There is a small door and i want to get some smoke
coming out under the door there.

For that i would love to add the “Dry Ice” PyroFX and i am facing one Task to tackle there …

  • How can i set my Groundplane (exported from maya as FBX) as a coliderplane for the PyroFX Dry Ice so it does not fall throu the gorund.

Again i can not find anything somewhere … Gnomonworkshop does not have any tutorials for Houdini at all and Pluralsight only features smoke tutorials where smoke goes up and does not need to float on the ground.

So sry again that i am asking such a simple question for you to answer. But i am working mostly in Nuke.

Best Wishes



so is it safe to assume you used the shelf tool ‘Dry Ice’ and got something going already…except it’s not colliding with your Maya floor ?

let’s assume yes, quickest way to proceed is click on the Collisions tab up top, click on Ground Plane…this will auto add a ground plane for you
and your smoke should collide with it…run the sim to verify that it works…

  • Now open up your pyro sim, press L to get nice layout, you’d see a Ground Plane has been added…currently this is your collider…but you don’t want it, you want your Maya floor, right?
  • rclick and add a Static Object node. In the OBJ Path, click on the right most icon to select your object…select whatever your Maya floor is called
  • in the SOP path just above it…do the same but now select the bottom most node in your Maya object network…most likely a Transform as you might have rescaled or repositioned the object.
  • now wire your Static Object into the Static Solver, overwriting the previous connection from the Merge of the Ground Plane…ie. now you’re using
    the Maya floor instead of the Ground Plane…

See how it goes…


Hey Vusta,

first of all thank you so much for helping me here but it seems like i am doing something wrong here.

This is what my Network and the new node looks like.

But it seem there is something missing here … any idea ?



And using the Static Object Button in the Shelf seem to not work too.

So fort clicking the object and then the Static object Button


OK i got it now … ! Thank you again … my floor was just to thin

Now i do have the Next question.

How can i render only the Smoke out without the Geo so i can comp it in nuke into my Cam Projection?

  • when your smoke is passing thru the ‘collider’, I think it’s because the steps are too few. In pyro_sim, pyrosolver1>Advanced tab, if you increase Maxsubsteps to 2 or 3…it should fix the leakage (I used a flat plane, with no need for thickness…and it works)

  • for rendering, I’m no expert but probably the quickest way is to go up up up to your highest level, you should see your Maya floor object having the Display flag blue, click it to turn it off. It shouldn’t come out in the render anymore.


A little late but in case you didn’t get an answer.

The rendering - Go to the mantra node in /out. Click on the objects tab. In here you can select what is rendered and what isn’t. You need to add the ground plane to the “Forced Phantom” object. This will not render the ground plane but the geometry will interact correctly with whatever you are rendering. For instance if it was something reflective, then the ground plane would show up in the reflections but not in the render.