pmg fix that interface before working on 5


Its kind stupid that messiah is up to version 4 and its still has some kind of interface issue. Btw, yes I did all of the tips in the flicking thing. And on another note how is possible that they ( pmg) blame video cards for the OpenGL problem, as if their the only ones using openGl for 3d. I don’t have this problem with any of my other software apps. Yes one could say stick with those, sure give me back my money then.

I had the flicking problem fixed. The other day I load a city, not large at all. Just few buildings and ran fine in LW3d and Modo. But in messiah omg, while in perspective view and camera view, when rotating, zooming in and out, the entire icon in the interface would start to rotate shake and move around. By the time I was done zooming out so I could see the building, not one icon was left in it default location. Including the zoom and dolly icon on the right of the interface. Shoot I couldn’t even click on any of them.

Looks what ever the problem is, whether it’s the video cards or bad code on messiah’s side, this has to be looked into and fixed.


I understand how frustrated you are; I have been in your shoes (and likely will be in the future). But I don’t think it’s fair to blame pmG and exonerate every other 3d software company. I use Maya a great deal and many people experience display issues with it; the first sticky in the Maya forum on this site has a 26-page thread about display problems. Even Autodesk, with its massive size and resources, has a lot of trouble nailing down OpenGL issues. In fact, Autodesk refuses to officially support consumer level video cards for Maya… so if you run into a display problem and aren’t using a high-end Quadro or FirePro card, they can’t (or won’t) do anything about it.

So in that respect, the fact that messiah runs so well on so many cheap, consumer-level gaming cards is commendable. The flickering and interface issues have been present for years and I’ve no idea who’s to blame. Hopefully pmG can figure it out soon – or at the very least, perhaps someone from the community can offer a suggestion that will help you out.


Well if this true then pmg should have on their website the video cards they support and drives they support. i would be glad to buy any card my major software requires. Or at lest specify before buying which cards work best and drivers.

i mean they really need to figure something out.


Btw your right about the high-end video cards support. Soildworks has a list of cards and drivers that are approved to use.


Can I suggest you post your card type, OS type, and drivers/things you have already tried



Like i said the flicking is gone. this has to do with icons moving around now when i have large items i guess.


Never had ANY such issues on a variety of computers.
Even using sub $50 nvidia cards messiah has worked without issue.
Have to admit I never used the ATI product though.
Why not post your system specs?


Well ok

Windows Vista 64. 6g ram
Intel core 2 quad. 2.33
Evga 1g Geforce 9800 gt or gtx i cant remember, im at work.
i have latest drivers install i know that.

My list of software that doesn’t trip

Houdini 10
Modo 101 201
Lighwave 3d 9.0-9.6
3d-max 5
my adobe stuff.
um i guess that’s it.

oh Vue 6


Have you checked out that Rivatuner utility?


well no. only because i was told this was an older software then what comes with nivida and i could run into system problems . Also after reading over the overview i really couldn’t see what it would do for messiah other then the flicking thing. i figured it wasn’t worth using just for one app. Like had said i don’t flicker anymore since i set my AA 2X. its just these dang icons move into a diffrent location after loading some building.


A good rant. :slight_smile: Did you email pmG support about your problem? I can attest that Modo has huge flickering problems and will crash a lot whenever I move or attempt to modify a part of the interface. I’ve emailed Luxology repeatedly with the problems I’m having and my system spec details. I have yet to get a response. messiah runs smoothly on my computer with no flickering, etc. And I have a mobile gfx that is very low-end (which Modo apparently doesn’t like! :slight_smile: ). All my other apps Silo, XSI, Blender, etc run just fine. I understand your frustration.

My biggest recommendation is to email pmG support. I generally get a response in under a day when I’ve had an issue. But I’d give them 24 hours. And make sure to provide system spec details and communicate what you have tried.


He’s talking about the armature buttons; they’ll do that when zoomed out really really far, as can happen if you’re doing something big (like city streets) in real scale. We’re looking into the issue. Of course, if you’re not using those buttons you can delete or deactivate them in Setup–>Armatures. Those are just samples, anyway, and I don’t think most people use those particular ones (well, maybe the new animation ones).



Yea I have had that problem before when I have had to pull way back on something. Pretty funky but not exactly hard to work around. . .


Heh well, guess what, you can adjust your grid size too. At least it works for me better than zooming insane amounts (when armatures start to go crazy). Adjust your grid size.


Sounds good peksi. How about letting me know how you set the grid size. Is it the same as in lightwave. this way i can test it out.


Yup. Even the same keyboard shortcuts. [ and ]


I came across a another problem I’m having. When i to to set up a material with the nodes. i the preview sphere is black. yeah i tried changing mode but its just black. not sure if this make sense. one example is i add a noise node, i middle mouse click and the preview window pop in. That’s it, just black no noise, sphere. I’ll try this out again. maybe ill drop some screen grabs for you guys.

thnx for help.


Maybe the scale is too large…?



I think you have to plug it into something in order for it to show up, try plugging the value you’re trying to see (the noise) into for instance, the colour channel of the main shader, or wherever is most useful. I think this is due to the shaders not being evaluated until they are needed.


About the Video Card Flickering. This took place on more than one machine and on more than 1 type of card although both were nVidia cards. I went from a 6800 on my old machine to a 285 on my new machine. Same problems.

The solution is to manually set all of the features in your Nvidia Control Panel. Crack everything up pretty high. It nips the problem in the bud. I’ve found after tinkering a bit, if I have anything set so that the application handles settings, I get flickering. You can save it to the program settings so you only have to set it up once. That worked for me.