Particle Emitter not rendering properly; particles stop emitting


#1

I have a scene with tracer bullets flying through the air, and my particle emitter shooting the cylinders.
Everything looks fine in the viewport, and even when hitting play and stopping and rendering the current frame it looks just fine and normal. However, if I render any frame other than the one I’m on (like when I render all frames), or if I go back to start of the timeline and hit render on any frame at all, the emitter has stopped after only a dozen or so frames. It is not behaving like I set it.
I have birthrate for viewport and render both the same, and everything should work. I don’t know what I can do. I don’t see any option to bake, and I am not using dynamics, which would allow me to bake I suppose.

Is there a way to render properly with emitter, or should I just try to set dynamics tags and adjust the speed and bake my emitters?


#2

Have you checked “render instances” ?


#3

No, but I tried with and without that checked and it did not fix my issue.
I have the lifetime set low, because I want the particles to disappear once they reach a certain point in the render, which they do exactly as I want in the viewport preview.
Is this messing it up?
I have the emission stop set to the end of my timeline, which is 120 frames, but the lifetime is 30 frames.
But why would this cause them to stop emitting early on if I have emission stop set to the end of my timeline?


#4

I have tried many things, but for whatever reason the emitter simply stops emitting particles after maybe 30 frames or so.


#5

Can you share a file ???


#6

My birthrate editor = 5
birthrate renderer = 5

start and stop emission is 0 to end of timeline
lifetime is 25 F
show objects checked (but that is only for viewport, right?)

with these settings, why would the particles stop emitting at 25 F instead of emitting 5 particles each 30 F until the end (120 F)?
My render has no particles after they stop early on, but my viewport preview shows them emitting as they should.
I simply have an emitter as a parent of my cylinder.

EDIT:
I thought maybe I was misunderstanding the meaning of lifetime, but even putting that to 120 F still shows the particles stop emitting after 25F but they are just now visible until the end of the render.

It must be a bug or something with my render engine.
If I play the preview in the viewport and let it run, pause it, then render that current frame, it renders with the particles emitting past 25 F. But if I render an individual frame not the one I am currently on, it shows the particles have stopped emitting early.

Either that or it is something like a ‘bake’ issue with the rendering, but there is no bake option for particles.


#7

There is a section in help, but I’ve only up to R21.

or check this tut (5 yrs old ) by The Pixel Lab
https://www.youtube.com/watch?v=Jj4BY5ztXm8

Hope it helps, if you still have issues maybe worth uploading a cut down scene file .
Cheers


#8

You’re a lifesaver. It worked.
Baking the particles fixed everything.
Such a weird tag and hard to find at first.