Opacity Channel - Alpha image: white border


#1

hi!

I’ve two .tif images of a leaf: one for the diffuse and the other for the alpha.

I notice that once applied the alpha image a little white border appear around the silouette of the diffuse image, I can see both in the material preview and also in the final render.
It seems the alpha image doesn’t cut correctly around the diffuse image, but it is some pixel bigger and so I see also the white area of the diffuse image.

It is a common problem that I can solve in the bitmap parameter?

Thanks a lot!


#2

You just have some edge bleeding–Best thing to do is go back into photoshop and change the background to something green to match the leaf so that it doesn’t have that white there. You could even try extending the edges of the leaf to use the same color.


#3

How are you using the maps in 3ds Max? Sorry too many possible variations to know the proper resolution.

For best results it is usually better to combine the diffuse and alpha in an image editor and save them out combined. Then make sure that the bitmap map is properly to premultipled or not for the alpha.

-Eric


#4

Don’t forget to turn off filtering for your map (in the bitmap parameter as you said). It’s the most common cause of the white border you describe.


#5

Did you find a solution? I have a similar problem. PNG image: alpha edges bleed out 1 pixel so it seems.


#6

Hi!

Well, I don’t remember very well… it seems to me I haven’t solved… but if I remember I’ve changed the diffuse color of the diffuse channel and made it similar to the color of the leaf accordly with the bitmap, it seems that the diffuse color of the material (under the bitmap) is taken in consideration in some way, so the white border around the leaf is “dirted” by the diffuse color of the material.

Good luck!


#7

thanks for you reply!

I also did not find a solution, but I have a workaround for my case. All objects have only 1 color anyway, so I decided to give each material its color for the diffuse (simply diffuse color property instead of a bitmap) and an opacity map made in photoshop. No white edges :slight_smile:


#8

If you or someone else locking around here still haven not find a good solution.

Do this:

1: Make a copy of your beloved "alpha mask"
2: Paint the Background as you prefer instead of white, Then "Flatten Image".
3: Load you "alpha mask"
4: Select Background Layer  & press CTRL + J
5: Delete Background Layer Save your masterpiece.

Use the image, be happy and try not to forget the little trick again, i do to often...


You may also:
• Download and use "[AlphaUtility.atn.zip](http://docs.unity3d.com/Documentation/Images/manual/AlphaUtility.atn.zip)" Before you go to step 2.

Its a Photoshop action, read about it here: ===> <===


#9

If you have a diffuse map assigned, please try setting the swatch for ambient and diffuse to black.

For some reason, even if a diffuse map is assigned, the swatches have an effect on semi transparent pixels.


#10

this works in 3ds max 2012


#11

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.