nuke noob problem with zdefocus


#1

Hi guys, I having problems with z defocus i keep getting a “zdefocus: couldn’t find function” same thing with the motion blur node.

thanks


#2

i haven’t seen that error before… that said, do you have the node connected correctly (the image input is your source) as well as a proper “depth render” in your depth channel?


#3

I get this message


#4

it’s hard to read the error message in red at the top of your viewer.

and i see you have a depth map near the lower right.

try using a shuffle copy 1. your depth image 2. your full RGB image

in the shufflecopy click the top left red box…and then over on the far right open the grey rgba pulldown to other and zdepth.

once you have it piped in this way zdepth will see the correct channel it needs.


#5

thanks for taking the time to help me out with this.

It says “Zdefocus1 couldn’t find function o7daa95…”


#6

in the past i have contacted the foundry for support. they are actually pretty good. you might want to consider that.

your error is kind of unexplainable to me. it’s hard to say if it’s software or hardware at this point.

also, to save a step in the future you might also want to delete that shuffle1 node there and on your shufflecopy the top left would be RGB then check the red box.

i also noticed your using png files. if you use targas or tiffs do you get the same issue?


#7

Hey, we were having the same problem and it ended up being a combination of GPU settings and having low disk space for cache,
maybe try changing your cache location.
hope this helps!


#8

Had the same problem, except for GPU settings (on old graphic cards for example) it also may be a problem with your username. In Temp directory there is a folder named “jitCache-” which Nuke uses for nodes with GPU mode, like Kronos, Denoise and others. In case when your name contains non-english letters, Nuke won’t be able to use this folder even though it was created by Nuke. So you’ll have to change the name of the account