Multiple audio reactors: Keep some active without passing audio to preview or render


#1

Sorry for such a basic question, but even tuts I thought would mention this did not:

When I uncheck an audio reactor, it stops playing, but also stops reacting. I need it to react, but not play the audio… and not pass audio to the final render. Mind you, I can’t disable audio overall because I do need the one main audio track to play (and render) I’ve got a ton of little videos to output, so trying to set it up so I can just do so straight to mp4 from c4d without any further compositing in another program, and need only the main audio track to play.

I’m assuming it’s something simple, but not seeing it for some reason.


#2

Thought I’d found it. There is a solo button per track on dope sheet, and at first test, that seems to do the trick in that it mutes the other audio reactors while still allowing them to function.

I have very little keyframe animation, though, and I see now that that acutally solos the animation, so keyframes on any other object stop working. I suppose I solo every track EXCEPT the audio reactors I want muted, but that seems kludgey at best.

Is there a better solution?


#3

Still looking for a better solution to this. Clicking on the little filmstrip in f-curve animation window for all the ones I don’t want to hear allows them to still function without passing audio, but then also disables any animation on those tracks, and fails to save with the project, so every time I open it, I have to remember to go back in and re-disable them.

I’m still assuming there’s a better option I’m missing.


#4

Assuming you’re talking about the sound effector object:
Add the sound effector
Select an audio file
Open the timeline dopesheet
Select the sound object

You should now see a “Use sound” checkbox for in-app playback, turn this off. and yes, it is in a crap place.


#5

Got it. Thx.
I must’ve studied every inch of that dope sheet f-curves, etc a dozen times along with every option in every tab of the effector.

I guess I should’ve thought of some type of properties tab. Does seem odd that it’s not just on the effector.