Missing Textures and Geometry in Renders


#1

I’ve been trying to render something and noticed that a couple pieces of geometry are not showing up in the render. It’s the top and bottom teeth of a character and it’s all part of one object.

When I went to the surface and materials windows it shows a little red X on the Ball icons for each texture. It looks to me like everything is there and turned on as far as I can tell, but I must be doing something wrong.

This my first attempt at rendering in 3 by the way.

Anyone have a solve? I’m sure this is stupid easy to fix.


#2

Here’s an image that shows what I’m going through.

ps. How do you get some of the kind of procedural textures that you have in LW, specifically veins and crumple?


#3

oh i hope some one can help you. i also had a similar problem. couldn’t figure out what was going on.


#4

It’s strange because the actual model is all textured properly and the UVs are okay and everything.

When I get into Messiah and start looking around for everything it shows that I don’t even have UVs for that stuff.

Now I will say this: when I first started this project in messiah I had the teeth and tongue as separate geometry and I didn’t like what I was getting so I went back to LW and cut those out of their original layers and paste them back into the head geometry layer.

That may have something to do with it, but the data should still be there so not sure what is going on.


#5

Is it possible that you have another texture for the teeth, and that one labeled teeth is for the “old” separate object. That would be its "x"ed out.

If that’s the case, maybe there is something about the “real” material surface…such as Diffuse turned off, or the Surface turned off, or the material Transparent.

Did you map a white texture onto the teeth, and accidentally have that acting as an alpha…making it transparent?

Just some quick thoughts…

Best,
Rick


#6

Good suggestions. I’ll looking into those and get back to you.


#7

Alrighty then.

It is resolved.

I have some screen shots that will hopefully shed some light on what happened.


#8

SO, the materials where there, they just weren’t applied to the surfaces.

I went to the surfaces tab and found surfaces with no materials attached.

I selected the matching material with the X on it and clicked on the “apply material” button.

That was pretty much it.


#9

Glad you got it sorted. :slight_smile:

Messiah does add an extra layer over Lightwave.

Lightwave = Texture -> Surface.

Messiah = Texture -> Material -> Surface.

The advantage is that you can use the same material on lots of surfaces.

The disadvantage is that its one more thing that can go wrong. Once you have made the mistake once though. . . you never do it again. :slight_smile:


#10

yeah that layer system in messiah kills me. I wish it was better organized. I have to check this out and see if that fixes my old problem.


#11

Where are you confused?

Most of the 3D apps I have used have worked the way Messiah does. It was a real hard adjustment moving to lightwave. I’d animate a value in a texture and that would somehow get saved with the MODEL!?! Oh that made me so mad. I’d load up that .lwo into another scene and the textures would start moving around. . . :banghead:


#12

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.