Metallic reflective material rendering extremely grainy


#1

Hello!

Would anyone have any idea why my metallic reflective object is rendering so grainy? i keep getting this terrible grainy quality overall and then those massive white dots in the upper right hand corner.Attached below is an image to demonstrate the problem as well as the c4d file.

any and all help is greatly appreciated!

c4d file.zip (4.9 MB)
problem%20with%20metal%20rendering


#2

If this is Redshift raise your Reflection samples by a significant amount. Look in the Overrides section.

Because the OP doesn’t bother saying which renderer they’re using it makes it impossible to give specific advice but speckling like that is almost certainly caused by a deficit of samples and your only option is to raise the sample count until the noise clears. The uneven nature of the render also means either adaptive sampling was not used or the renderer doesn’t have it. Look for options such as Multiple Importance Sampling (MIS) and make sure it’s turned on.

In rare occasions I’ve seen this from ‘bad’ HDRIs but that normally affects the whole render.

Two people have downloaded the file so can you put me out of my misery and confirm what renderer is being used and what the settings are? Thanks.


#3

yeah this is Standard


#4

You’ll get better results faster out of Physical… but that’s not saying much. Glossy reflections in AR3/Physical are just slow to calculate, full stop. You’ll need to chuck more samples at it or switch to another renderer, and depending on your deadline/budget it may be cheaper to get a 2-series nvidia GPU (e.g. 2070) and try out Octane.


#5

Unfortunately I can’t advise on Standard or Physical as it’s approaching 10 years since I used either.

If the OP doesn’t have a suitable GPU for Octane but they have an OK CPU they should consider Corona Renderer which will give them the best possible performance and quality from their hardware.

The next step should be to write a strongly worded email to Dave McGavran asking why he thinks it’s acceptable to ship god awful renderers in a premium product in 2021?


#6

Okay, I tried this with various settings, but then realised you have some Specular on the metal. If you set it to zero, you lose those noisy grey panels and the highlights. it should be zero anyway on a PBR material, as it’s a fake effect.

I can render an image noise-free with Physical in 1:26 at 1280x720 (24-core Mac Pro). If you want those highlights I suggest you try using a different lighting setup with area lights or a studio HDRI. If not, then you’re going to have to crank up the sampling settings (also, in Physical, you can increase the Blurriness Subdivision setting to 4 or 6 which helps).

Looking at the scene again, I think you just need to simplify it. There are too many reflections of reflections going on, which isn’t helping. What kind of image are you after?


#7

With physical renderer, unchecking specular in the lights themselves will speed up the render (provided you go for a full reflectance material). The denoiser also works pretty well with physical renderer.