Mental Ray - Shaders


#4581

Seriously that doesn’t work, well I cannot get it to work.
If my render settings AA is lower than the Geoshader that kind or overrides geoshader settings.
As far as I remember the Geoshader AA settings have to be within the range of the Render settings AA.
I’d like to see your test scene ?
cheers


#4582

I didn’t manage to get 2009 version shader working with 2010, so I’m wondering if there’s a 2010 shader I can use for rendering? I am way past using simply final gather for renders and was disappointed not to see it as an option in 2010.


#4583

… it works perfect :thumbsup:

here is the scene:

http://rapidshare.com/files/225261513/Ctrl_ObjecT_A01.max.html

cheers

Klaus

The new geoshader for 2010 is at maxplugins.de


#4584

The way that I understood it, the aa settings in the render settings is the range for all objects that are not included in the shader. I use two because I did not want anything to render 1/16.
I wanted some objects to render at 1/4 and the rest to render at 4/16. If any objects were not added to a shader, they would render at 1/16. Isnt this correct ?

Regards,
Mike


#4585

But could you -please- give me a link? I am unable to find it, keywords ctrl and geoshader and such have no results when using the search, and the list itself is very long to browse through if the keywords themselves do not match.


#4586

I am guessing he is refering to these 32bit and 64bit. I just searched for “geo” and these were the first items returned at maxplugins.de.

-Eric


#4587

Thanks, I’ll try. I searched with ‘geoshader’ and it provided 0 results, as did ‘ctrl_ghost settings’ and ‘ctrl’ (providing only color).


#4588

Could you please provide the links? I tried the one posted few posts above, but they throw errors when opening your scene. Thank you.


#4589

… that´s it !


#4590

http://rapidshare.com/files/225450417/mrGeomShaderObject_Max2010.zip.html

put it in your plugins folder
and

http://rapidshare.com/files/225452052/ctr_object.rar.html
put it in your mentalray autoload

that is the shader i talk about ! … and that does the trick … no ghost !

These shaders are originaly from maxplugins.de! I am NOT the author, just trying to help out and hope that it´s OK for the author.


#4591

Hmm, I tried installing it but it is throwing errors, saying that ‘mentalray\shaders_autoload\shaders\ctrl_object.dll is not a valid Windows image’. I’m trying the 32bit one on a 32bit Windows XP system, on a trial installation of 3ds max 2010. Perhaps plugins don’t work anymore on trials?

 I tried downloading and setting it up again, with no luck, so the files are definitely correct. Did yours work on 32bit?

EDIT: I believe you have uploaded corrupt files. It did not throw errors when using the one from maxplugins.de, but then it -did- throw different errors, about ctrlColor.dlt being missing. Using the one from maxplugins.de didn't get it working either.

Confused here, since my colleague did get it to function at work on a 64bit station. Won't be able to test it myself before Monday though.

Any other suggestions?

Not to mention, anyone knows why Autodesk did not include importons and irradiance particles in 3ds Max 2010 in the first place? Kinda silly, considering they are production-ready for at least image renders. More silly, considering they were already in 2009, a year ago, hidden. And one more notch, considering new XSI and Maya supposedly have them.


#4592

… sorry, i work on 64 BIT and it works fine here … installed on two different machines … can´t tell you about 32 BIT … sorry that i could not help you …

My Specs:
WIN XP 64
3DS Max Design 2010
8GB RAM


#4593

Yeah, thank you. At home I’m on 32bit Trial version, so I’m guessing that’s the problem. Anyone’s gotten it to work on that?

Maybe it’s the 3ds Max 2010 and Design difference as well?


#4594

… try to download the ctrl-object shader for max 2009 that should work. There is a 32 and 64BIT version. i also use the ctrl-object shader for max 2009 !!! - 64 BIT

Use this with the mrgeomshaderobject.dlo i uploaded for max 2010 !!!

that should work.


#4595

Still without success on 32bit trial, I also tried reinstalling.

Could someone with 32bit system that has gotten it to work (as in, not just downloaded the files but also tested that it runs without errors) please upload their files? I can’t think of anything else anymore.

Thanks for the help so far :slight_smile:


#4596

Are you just getting error messeges, or is it really not working ? Some of the error messeges in the MR log are normal, and can be disregarded.

Regards,
Mike


#4597

It works fine here on 32bit 2010. The error message about ctrl_colors can be ignored, it’s just a missing plugin message.

Dave


#4598

Interesting, I did not test further than the test scene shared above (which didn’t function), because of the error messages. I never had any error messages thrown when using 2009 and it’s really uncommon.

But it is not just the colors error, it is a critical error saying that ctrl_object.dll is not a valid Windows image.

Then after it has loaded and started up, it throws:

LINK 0.0 error 191007: cannot load ./ctrl_object.dll, unknown error code 193, check Win32 manual
API 0.0 warn 302004: ctrl_object.mi, line 23: while defining declaration “ctrl_object”: declaring nonexisting function ctrl_object

I am using the files posted by tryhard on rapidshare.

I must be doing something wrong, but I’ve not had any problems with 2009 or any other plugins.

I tried again from the start by doing:

  • clean install of 3ds max 2010 (non-registered, runs in trial-mode) 32bit using default settings (I originally installed to custom folder, but now tried basic)
  • added tryhard files (32 bit ones) to 3ds max 2010 installation folder

It throws errors when starting up, I tried with and without the Hotfix.


#4599

Okay, let’s start again from the beginning…

  1. Download the mrGeomShader plugin:
    http://www.maxplugins.de/r2010_files/maxplugins/mrGeomShaderObject_Max2010.zip

  2. Put the 32-bit version of the plugin in your Max ‘Plugins’ folder

  3. Download the ctrl_object shader:
    http://www.maxplugins.de/mr_files/ctrl_studio/ctrl_object.zip

  4. Put the file ‘ctrl_object.mi’ in your Max/mentalray/shaders_autoload/include’ folder

  5. Put the file ‘ctrl_object.dll’ in your Max/mentalray/shaders_autoload/shaders’ folder

  6. Start Max… there shouldn’t be any error messages during startup. I certainly don’t get any using the exact same plugins / shaders listed above.

If that works, we can start trying to find out why the scene file doesn’t work for you…

Dave


#4600

Ah, thanks, no errors now :slight_smile: It seems theres a 63Kb size difference between the ctrl_object.dll 32bit file on the one you gave me and the one from tryhard uploaded archive. This seems to have fixed the error, thank you :slight_smile:

But now the test scene, what am I supposed to see there exactly? It’s definitely not your average global illumination style scene to check whether importons and irradiance particles are working or not, it just has two green cubes and another gray one, all looking quite non-shaded. What is the test scene intended to show?

And during rendering it throws:

PHEN 0.3 error: ctrl_object->object:: Box01|GeomObject(Mesh00)

Which is confusing as well. Is there a test scene which makes it more apparent if it works or not? My old Max 2009 scenes don’t function because the plugin is different (looking for Ctrl.Ghost.Settings).