Maya takes EXTREMELY long time or FREEZES on saving the file.


#1

Hello, dear fellows!

I’m asking you for help with my cartoon scene. My file has started behaving bizarre: it takes much more time to load now and what’s even worse, the saving process takes unreasonably much time! Like the file is just 100MB and it’s being saved for 2-3 minutes. Also some strange stuff is happening when saving: after the first save time the file’s size suddenly becomes about 700-800MB (if saved successfully and not froze), but after the next immediate save (with no changes to the scene) it comes back to its original 100MB size. That’s something completely confusing to me, but maybe that could be kind of a clue for you.

Initially, the scene contained about 11 referenced files in it (including 6 characters with rigs). But as I worked on the file (adding animations), its size grew up to 400MB already and then these saving issues took place. So it was unbareable to keep on working with it anymore and I decided to start another separate file for the 2nd part of my cartoon. So basically I dublicated the existing 400MB file and deleted all the references except the environment. I did that just to keep my light and environment settings unified for both files.

I started then adding character references all over again. Since they are “empty” yet (with no animation data), they didn’t affect the size of the file itself. BUT the abovementioned saving issues began.:tired_face::tired_face::tired_face:

I looked through all the info on the internet I could find, tried lot of things but nothing helped. I guess I’m missing some redundant data which I can’t pick out of the file myself. Here’s the things I tried out and of no help:

  1. optimize scene size
  2. saving .mb instead of .ma
  3. importing into a brand-new file
  4. delete light linking nodes (via MEL script)
  5. check for multiple UV-sets
  6. clean Outliner

I’m attaching the dropbox link with the scene. If someone could look through it, please, and maybe give me a hand! I’d appreciate it so much!

P.S. I use Maya 2018.
OS Windows 10.
Save the file to harddrive.


#2

Couldn’t open the file.


#3

hm, that’s strange! it opens fine on my edge. did it come up with any errors while opening?


#4

Hi, I opened it fine, but there appears to be nothing in the file, in the Outliner I can only see lights and some constraints.

A lot of references in a Maya file tends to slow it down a lot when it comes to saving and opening the file.

There are heaps of posts about it on these forums, such as the one below:

Have a look through the posts and hopefully you can find something that has been suggested that may work for you.


#5

Thanks a lot for your reply and your efforts with file opening! I will look through the topic, suggested by you, maybe there’s the way out for me there. Cheers!