Maya crashing when moving time slider


I’m experiencing this problem for the past few days and can’t find any solution.

I have a rigged character with Xgen fur and wrap deformers.
Next step was to add blend shapes for facial animation and connect them to controls via set driven key method.
Shapes work fine when moving the controls.

Now the problem occurs:
When I move time slider (even if there is no animation) Maya just crashes.
Tried to delete blend shapes and slider works normally.
Then I’ve redone the shapes and same problem is still here

Somebody knows what the problem might be and how could it be solved?

Thanks in advance!


it seems that the issue is only occurring in viewport 2.0,
still don’t know what’s causing it

I’m using Maya 2017


you could try to turn off parallel evaluation and go back to DG… and turn off GPU override…
those settings are in the prevs under Animation Evaluation…

parallel and GPU is turned on since 2016 but if your graphics card or your rigs arnt parallel conform this will lead into troubles…

more to read here…


Yep it seems that going to DG fixes the problem,
It’s funny that turning off GPU was the first thing I tried but forgot to switch to DG from Parallel.

Thank you for fast response,
You helped me a lot.


This problem has not been solved even with DG and GPU. As I am giving keys to a rogue character and moving the slider to the next key or deleting an old key, it is crashing again and again. I think there are a lot of newbie developers working at Autodesk. In their quest to advance, they have spoiled the quality of Maya.
It would be better if Autodesk provides Arnold separately with the old Maya which is compatible with the old versions.