Maya 2018 Cached Bifrost Simulation SIGSEGV Invalid Memory Reference


#1

Hi everyone,

I am completely at a loss. I have cached, meshed, and mesh cached a Bifrost fluid simulation, and every time I set up to Render Sequence, after 3 frames Maya crashes with “3608MB ERROR | signal caught: SIGSEGV – Invalid memory reference”. My laptop is a:

MacBook Pro (15-inch, 2016)

Processor: 2.6 GHz Intel Core i7

Memory: 16 GB 2133 MHz LPDDR3

Graphics Radeon Pro 450 2 GB Intel HD Graphics 530 1536 MB

Maya 2018.1

MtoA 2.0.2

Arnold Core 5.0.1.2

I have:

  1. Tracked the memory usage throughout the render and it never takes more than 4GB of the available ~12.

  2. Dropped the Bifrost Options > Max RAM Usage to 6 just to be absolutely safe

  3. Changed the bifrostLiquidContainer > Evaluation Type: Per Frame

  4. Made sure Preferences > Dynamics > Run up to current frame is UNCHECKED

  5. UNCHECKED Autodetect Threads

  6. UNCHECKED Scratch Cache

and none of these did anything to change the outcome of the 3 frame-at-a-time render I fear this project is doomed to.

It plays fine scrubbing through the viewport and rendering individual frames look great (got a good one mid splash below), but the moment I run a Render Sequence it all goes to pot.

Here is a link to my file, minus the multiple GB caches, obviously: https://www.dropbox.com/s/t2uzd21wygi9hbh/baconShampoo_v2.ma?dl=0

and attached are the logs from my last 3 frame render.

ArnoldLogs.zip (19.3 KB)

Please help. I have scoured the ends of the internet and nothing I’ve found has worked.

Cheers,

Edan