MAXScript Editor: how to turn off "Use Monospaced Font" option by default?


#1

Hello, everybody!
In MAXScript editor 3Ds max 2021 the “Use Monospaced Font” option is always turned on by default and I always have to turn it off by “Ctrl + F11”, because I am not comfortable working with such a font.
How can I make this option disabled by default in MAXScript editor?
Thanks for help.


#2

In case if you won’t find a setting that turns in on/off put it in startup scripts folder


-- IDM_MONOFONT 	Toggle Use Monospaced Font 
windows.sendMessage (dotNetClass "Autodesk.Max.GlobalInterface").Instance.TheMxsEditorInterface.EditorGetMainHWND 0x111 450 0


#3

Thank you, but unfortunately this method only works once when you open the MAXScript editor and only on the last opened script. When creating a new script, the option “Use Monospaced Font” is again turned on.
I still could not find in what settings this can be turned off :frowning_face:
I compared the MXS_Editor.properties and maxscript.properties files in 3ds max 2020 and 3ds max 2021 - they are absolutely identical, but in 3ds max 2020 the option “Use Monospaced Font” is disabled by default but in 3ds max 2021 this option is always on every time when opening scripts or creating new ones i have to disable this, which is very inconvenient.


#4

Wow, that was unexpected :confused:


#5

For me, this was also a surprise. Is this problem only for me and no one can help me?:frowning_face: