Lots of Geometry in Distance Slows Down Render


#1

I have four square planes cloned radially to create a square tunnel, and then that tunnel cloned linearly to increase its length. The material being applied to each plane has a displacement map using sub-polygon displacement with a subdivision level of 8 to create details on the tunnel. Whenever I go to render a frame in the animation, I notice that the render buckets quickly work their way around the image except for one at the very center, which stays there long after all the others have finished (and hence only one thread is working on that section):

I assume this is because there is so much geometry at the very center because the tunnel is cloned to be so long. I’m wondering if there is any way to speed this up without actually changing the geometry of the scene; of course I could decrease the number of clones or reduce the sub-polygon displacement subdivision level, but those lead to other problems. Is there some other way to speed this up?

I am using the standard renderer.


#2

2 things, first would be to try physical render, this is the sort of scenario where it could well help. Secondly there is a super rarely used setting in the antialiasing settings called “small fragments” which deals with tiny <1 pixel elements. Try the two alternative settings.


#3
  1. why planes and not just one normal elongated mesh ? (you don’t have to answer that)

  2. Does the renderer decrease in speed as it reaches the centre ? If yes then it’s probably the large amount of polygons. Try replacing the last squares with disabled sub-polygon displacement and enabled bump.