Light Exclusion Not working in final in Redshift


#1

So I have some backlighting to my blood vessels and I only want the light to affect the blood vessels and not the surrounding granules. I have the light including only the vessels. Looks like it should in the IPR but in final render it seems to be affecting everything. Please tell me this isn’t a bug and I have a setting wrong.