Is there a way to restrict painting inside polygon islands or selected polygons in BP? [SOLVED]


#1

I hate when this happens

Is there an option to limit the bleeding so I can paint freely ?


#2

Select the polys you want to paint, then hide unselected. Paint on your poly and when done unhide all. Might be a better method, but it works.


#3

I have tried painting on the model itself but the problem still remains when my brush has a fade. The 3D brush due to its size paints neighboring islands even if they are not visible or hidden.


#4

You can just paint in a selected area like in photoshop:


#5

Can you tell me how to do that ? Is this the UV Editor ?


#6

You use the texture selection menu tools from the Bodypaint layout. But it doesn’t work for me. The only workaround I’ve found is making a poly selection set for each poly, and having a different material applied to each, then you can paint just on that poly.


#7

Yes, in the UV editor.

  • make a new texture (file > new texture)
  • make sure that texture is selected in the UV editor (textures > yourTextureName.tif)
  • create a new layer (layer > new layer)
  • make some selections and paint inside them (texture selection > select polylines)
  • profit

#8

Thank you it worked !
Actually I used the command Create Mask From Selection.


#9

@danielHinton

Do you happen to know why the following happens and how to correct it ?

I have a low-poly model under a Subdivide object. I paint on the low-poly model…
As you can see weird bleeds of the background occur between neighboring polygons…
I guess the Subdivide object is to blame for these texture inaccuracies but shouldn’t it try to “stretch” pixels to fit the new topology ? How can I solve this ?


#10

Have you tried switching the ‘subdivide UVs’ setting in the SDS Object tag. Boundary or edge might work.


#11

Thank you Mitchino

Screenshot_1

It didn’t eliminate the problem but it minimized it to a controllable state.


#12

I have found that you always need to paint over and a bit beyond the edge of your UVs to avoid those seams

if it is right the pixel edge of the poly you can get those


#13

I think this happens because the polygons are usually never rectangular on the UV map. Painting on non-rectangular polygons leaves some portion of the background pixels uncolored.
Using Grow Selection by 1 or 2 pixels solves the problem.