How to restore larger keyframe indicators in the animation palette?


I’m having a strange issue with the animation palette.
For some reason, it looks like this

With the keyframe indicator that small it becomes rather difficult to move the keyframes.
I can’t seem to find a way to restore its default look:

I’ve also tried to create a new animation palette as suggested in the help file to no avail:

Blockquote If your layout should lose its configuration to such a degree that no Timeline or Powerslider can be seen (and the default layouts are also missing), Drag & drop the Timeline Scroll Bar (Key Area) and Timeline Scroll Bar (Power Area) commands from the Customize Commands Manager into an empty palette to correct this.

Any hint?


A couple of points are:

In your first screenshot, it looks like you simply have less keyframes and therefore the key itself seems wider and vertically shorter, but not by much.

The other thing is that you probably have a font size for the interface that is different to default and/or your screen resolution comes into play. You may need to lower the font size in preferences.



right click on the timeline strip, try options/advanced mode


Thank you @Drew-Kerr @imashination

I think @Drew-Kerr is spot-on, the problem is due to the different font-size in my setup. I’m using a UHD screen and the default font-size is too small for me. Apparently, C4D doesn’t handle a different font-size too well, at least in my case.
I’ve also tried @imashination advice about the advanced mode. I get longer, thinner, indicator though strangely I’m not able to move it.


As you can see, the cursor now doesn’t seem to over the indicator:


I tried Draw Keys on Cells option but, as expected, it only affects the timeline, not the animation palette:

So, I guess I’ll just leave the situation as is. I wonder if there’s a better handling of UHD with C4D in Windows 10.
Changing the DPI settings for C4D directly in Windows seems to not solve the problem.


Advanced Mode will not let you grab individual keys by single-clicking on them, so is not going to help you.

Another potential solution, if you find them hard to grab still, is to use the Shift key and “draw” a selection around the key/keys first to select them in a group. This is not the same as individually grabbing them, but may be a solution that works for you.


Thank you, @Drew Kerr

The shift Key method works great.