How to change "HBP" to "XYZ" as a defacto rotation system?



I understand that Maxon has reason of choosing HPB as default but I just prefer XYZ as an overall default since I hope between other softwares and most (or all of them) uses XYZ.

I can’t see any setting in the preferences.

Is there a way around this?

Thank you for looking at my problem.



Choose your order and just go to Edit in the Attribute manager and choose Set as Default.


Hi Wzwaan.

Thanks for the response.

I’m afraid that’s not working. When I click a mesh, set as default XYZ. Yes it works. But if you create another one (even after restarting C4D), it still reverts to HPB.

The values in the constraints are also in HPB.


AAaarh darn it!! :frowning:

Also I do not understand why the order HPB is wrong in the timeline. Anyone?


I don’t follow. What do you mean by “HPB is wrong in the timeline”?


If the HPB is set in the attribute manager


The order is different in the timeline


Or did I press the wrong buttons :slight_smile:


Oh I did not notice that.
Hmm. Nice catch.


Anyway, anyone knows how to set the XYZ as the default rotation? Still hoping :frowning:


in the Timeline the HPB-Order (YXZ) will be re-ordered to the XYZ-Order or better RGB Color Order (Red-Green-Blue). That way it is in line with Position and Scale… so it is always Red-Green-Blue. I set the Preferences in the Timeline for the Track Color to be Track Color…that way it is easier to see that Pitch is red and Heading is green.

Sorry from what i know there is no preferences for that…i mailed maxon a lot about this over years and was hoping it will be adressed with the new Core Stuff, but so far no changes…maybe when the animation part shifts to the new core. But at the speed of Maxon this can/will take several years!


Great tip Torsten, thanks!


Thanks for the confirmation @TorstenSchneider
I appreciate it a lot.

Another bummer with switching from HPB to XYZ manually is it doesn’t carry over xpresso.
For instance, if you have HPB connected and switch to XYZ, the xpresso will break and you will have to relink over again.

Anyway, thanks again. Hoping for this update in the upcoming release.