How can I bake a riged body pose, to separate from bones and morphs but stay still in the pose and shape that I make?


I figured out that if I click with the right mouse b. on the body and then “current state to object” it bake the morphs but not the pose. How can I bake both the bones pose and the morphs shape to create a polygon object?



Uhm. It works on my end. I just pose a character. Click the the skinned geometry. Hit “current state to object” . And it creates a separate fixed geometry copy of that pose.


If there is no morph in the rigid body, than the pose is works for me too. But if there is a morph and bones too, then just the morph baked and the pose is not. If there is no morph and just bones, then it creates a separate fixed geometry copy of that pose.


Uhm. By Rigid Body, do you mean Rigid Body Tag?
Because when I read your the title, I assumed “Rigid Body Pose” as a “Static Pose” like nonmoving.

Anyway, can’t troubleshot further. I need an illustration file to work with.


I tought: Rigid Body = Boned polygon object, Rig = Bones/Skeleton, Body = (Any) Object

And I can give you an illustration but not on the original project but a similar one.


Hmm. We have the same procedure. But mine results as expected.
Maybe its a bug? Or maybe because its you are using an older version? I’m using the the latest R21 update.

I’m not sure to be honest. I need to have an illustration file to confirm. The illustration file need not to be the same file you are working one, just that it should have the same result.


I use R19 and I can send you the same rigid body in the illustration.


I can’t open the file for some reason. Sorry.


I have had the same problem in the past.
I exported the posed body (in pose) as a obj file,
then imported the obj file to project.


WOW… It worked!!! Thanks Alex.
De tényleg!

And bentraje, this is a .lib4d file so it is not a project or an obj file.
You need to Insert here: D:\Program Files\MAXON\Cinema 4D R19\library\browser
or here: C:\Users\User\AppData\Roaming\MAXON\Cinema 4D R19_C3FFBB30\library\browser

Then find in the Content Browsers and open it
But if you doubleclick that shod be fine too.