help: UV won't import into mudbox, no error given


I know that’s a really general subject. here’s the specifics of what’s happened:

I am working between 3DS Max 2015 and Mudbox 2015. I modeled a low res model in Max, threw some crappy 3-second UVW unwrap on it, then took it into Mudbox and did my hi-res sculpting. Then I exported the adjusted level-0 low-res model from mudbox back into Max, and did proper good UVW. I exported as .obj again and in Mudbox, I did File>import UV and chose the .obj. No error or anything occurs, it all looks like it has gone through correctly, but when I look in UV View all I see is a tiny version of the crappy first UVW I did in the beginning. I’ve been trying various things, but none of it has worked so far: I went back to Max to adjust my UVW and made sure to iron out all weird shaped polys and overlaps; no elements are near or touching the edge of the 1:1 area either. I tried exporting as .fbx instead of .obj as well. I tried “sending” the level-0 model to Max and doing the UVW there, then update the scene in Mudbox, and when I did this my model shrunk and the sculpting got messed up and exaggerated.

If I simply import the whole model from the .obj I made to get the new UVW off of, the model imports but is considerably smaller than the one already in Mudbox. This doesn’t seem right, and I could see how this might be the cause? If somehow the model got smaller when I brought it into Max to do the UVW, then when I try to import the UVW into Mudbox, it can’t line up the models and apply the UVW? I’ve imported it by matching both Vertex ID and Position and both times the result was the same: nothing happens.

My “object” is made up of multiple separate objects (body, teeth, tongue, etc) and I’ve been exporting and importing it all at once by selecting all. I don’t know if that complicates things or not.

I’m a student and am still quite new at this. Any insight or suggestions would be VERY appreciated.


personally i use fbx to go back and forth from mud to max.

as far as i know importing uv’s can’t be done with multiple geometries at once. i do it one at a time or import all the new geometries and assign existing materials where needed.


thanks for the reply. Importing them one at a time ended up working, though I still had to find a way to work around the weird inexplicable rescaling that happened the first time I connected mudbox to Max by “sending” my level-0 model to Max. I ended up saving the UVs that I’d made on the weirdly-small model from the Unwrap UVW modifier’s UV Editor. Then I exported a fresh level-0 model from mudbox (no connecting the two programs this time!!), re-importing it again to make sure it hadn’t been resized (it was fine.) then I took THAT into Max and loaded the saved UVs, THEN imported THAT one into mudbox (one object at a time, like you’ve said), and that finally worked. the UVs were finally imported correctly.