Help! Rendering sequence stuck after 1 frame on "Generating Lines (pass 2 of 2)", Sketch & Toon Cinema 4D


#1

Hi, as in the topic- renderer can’t get further than generating lines phase after rendering one frame with sketch and toon.
I tried rendering some frames selected randomly from the timeline and again, it worked only for the first selected frame to render- every next frame was stuck on “generating lines”.

Task manager in C4d is showing remaining and estimated time to render- constantly growing.

Screenshot_157

My PC isn’t even heavily used by Cinema 4d at the same time. Render is just stuck at it.

I tried different file formats, disabling multi-pass, changing resolution to lower, even lower than 1280x720 and it still don’t work.

If useful, PC specs:
Intel Core i7-10750H
Nvidia RTX 2070S (Super Mobile)
Samsung MZVLB1T0HBLR-00000 1TB SSD NVME
32GB DDR4 RAM

If you had similar trouble and managed to fix it- help please…


#2

This can happen if you’re either trying to sketch the wireframes of very dense geometry or your sketch settings are creating too many lines. This is my best guess not being able to see the scene.

Sketch and Toon is nearly 20 years old and still predominantly single threaded so unfortunately it cannot cope with some situations and just gets bogged down.

The Redshift developers have been promising a GPU based Sketch and Toon system for about 5 years now which has failed to arrive so one day, if you’re really lucky, you’ll be able to do this in real time in Redshift. Until then I can’t speak highly enough of U-Render which has got real time sketch and toon rendering now. If you do stylised rendering a lot then it’s worth a look.