Fusion 7 Loader Fail


#1

From the research I’ve done, this seems like a rather unique situation.

I’m compositing a 10 second title animation with passes rendered from Blender as image files, processed through After Effects for motion blur. The final PNG image sequences are then loaded into Fusion for final compositing. Everything has worked swimmingly all day—that is, until about 20 minutes ago when one of my loaders decided to fail at a specific frame, citing a “The handle is invalid” error.

I’ve tried re-rendering the problem frame, as well as the whole image sequence. I’ve also tried bringing in the single frame in a new loader, but it still fails with the same error. No other frames in the sequence (or composite, for that matter) are failing, even though every pass shares the same file type and output settings.

Support for Fusion has been relatively limited since Blackmagic purchased Eyeon. Has anyone else seen this before? Is there a solution that I’m just not seeing?


#2

After some more research, this is the solution I came up with.

Traditionally, programs throw an “invalid handle” error when an image file is not present in a selected directory. In my case, I know the image is there—but Fusion, for some reason, isn’t seeing it properly. To fix this, I simply told the loader to hold the previous frame until the node no longer fails (under the file settings). Because mine only failed once I was able to get away with holding the last frame without anything misaligning in the final render.

:buttrock:


#3

did you try to clear the cache of fusion? or sometimes its helpfull to clear the cache of just the loader (by make it “pass through” mode -> ctrl+p) or let it load another sequence and then set it back to the failed one


#4

Good question. Let me check… :wip:

Nope. Clearing the cache doesn’t seem to solve the problem. Not really sure why Fusion’s failing at that particular frame, but holding the previous on seems to be the easiest workaround. :banghead:


#5

Holding the previous frame is not a solution.
If u like send me the fail frame. I have had that before…so I think I know what the problem is. Can u upload it somewhere?

ViTO


#6

I realize that it’s probably not the best way to do it, but we were under a tight deadline so I couldn’t afford to research it much more at the time. It worked, so we ran with it :thumbsup:

Unfortunately I can’t share the file (legal reasons) but can you explain what you think the culprit was?


#7

Could u load the fail frame in Photoshop or the viewer?
When u load ur sequence in Fusion, once the loader window opens, Fusion shows u at which frame ur sequence starts, and where it ends…usually 2 numbers like 0…255
if it shows u 0…100…105…255…then frames are either missing or broken.

Could u try 3 things…

  1. open ur frame in Photoshop, convert it to 8bit…to make sure there
    are no weird values in there, and try again.

2.Fill it with black…try again…if it doesnt work…send me that black frame.

3.Load the fail frame in Fusion, and append a “set domain node”, view it…and klick “Set” inside the domain node settings. This one might not work in ur case though.

Let me know what happens…