Flickering/Shimmer Final Renders


#1

Hello,

After 10+ years off from using 3D software (used to be a Lightwave user) I’m really enjoying picking up Cinema 4D. There is one huge frustration though using it’s renderer… flickering/shimmering shadows in animations.

I’m currently doing a GreyScaleGorilla walkthrough, and it all went great except for this problem. Stills looked fine but I noticed bad shadow flickering on the seamless backdrop. I spent days rendering and trying different settings, finally I tried a different texture and upped the render settings and I thought the problem was solved. Nope.

I find the only thing that works is to disable Full Animation Mode for GI Cache Files. But well, then the shadows don’t move at all. I tried once again upping render settings, and THOUGHT I had it fixed but as you can see in the final seconds as the balls are rolling, there is shimmering/flickering in the shadows of the balls.

I guess I can turn off GI, but then the look isn’t the same. Any thoughts?

Settings:

Animation Sample:


#2

In the 10 years away from using 3D Software Maxon invested very little in developing their internal renderers. Don’t use Irradiance Cached GI in an animation. You are wasting your time.

None of the built in renderers in C4D can be considered fit for purpose, Physical Renderer is noisy and abysmally slow and ProRender is bringing CPU rendering speeds to the GPU. There are no good options in vanilla C4D.

There’s a reason why there was such a proliferation of 3rd party renderers for C4D and that’s due to Maxon’s inability to keep huge areas of core technology in C4D up to date. At the very least Redshift should be built in and not a paid extra.

Rent or buy a 3rd party renderer for your project.


#3

use qmc for GI in animations and bring enough of time, it’s going to be very slow. you’re better off either using prorender and some denoising or with a 3rd party renderer like redshift, cycles or octane.