Extruding is acting weird - wondering why


#1

Hello all…

I ran into this problem while extruding out polys… attached is a screengrab of whats happening while I extrude.

Please have a look as it’s much easier to see the problem in action.

I played around with a few settings and thought maybe the normals had something to do with it but… Im not sure whats going on here. Any ideas?

thanks for the help!!


#2

If possible, upload a file that shows the problem, but complete guesses without the file are you have a weight tag or bad geometry that is hiding a problem visually. Perhaps something like multiple points in one spot/close together/slighty misaligned or normals are wonky. You could try switching on Mode>Modeling>Mesh Checking - tick Enable Mesh Check to see if that gives any clues.


#3

hello drew… thanks for the help. It seems as though the problem occurs when I loop cut into the mesh… while adding more loops it duplicates the poly faces for some reason… I’m sure its a user error…

none the less… when i try to optimize geo… it doesn’t merge anything together.

Is there a way to dissolve overlapping points, faces, edges in order to clean up the geo?

thanks for the time


#5

If your geometry is messy like you suggest, the best advice I can give you is to recreate it. Your geometry in the attached screenshot is easy to recreate as it only needs creating once and duplicated another 3 times. Use tools like snap and/or parametric geometry to help start. Sometimes, trying to do things a quick or automated way can take longer than simple recreation and can lead to undesired results.

If you do want to try using Optimize, the only way it may work for you is to select the geometry, right-click and instead of just clicking on Optimize, click the black cog wheel icon to get to the options. Make sure you tick Polygons, Unused Points and Points and then experiment with the increasing the Tolerance number until you get a desired result. Be warned though, this may not help at all or make it worse.


#6

It’s not so much the thing I’m modeling, it’s more about cleaning up duplicate faces and points. The optimized gear provides options but didn’t do anything.

Its also a learning curve and understanding what’s causing the overlapping geo.

A work in progress. Great piece of software for sure.

Thanks for the time and the help

sincerely.


#7

You didn’t mention whether, when you were in the Optimize options, you tried altering the Tolerance number. You may have to experiment both increasing and decreasing that number to get rid of them. As I said previously though, this can sometimes work, but other times will make it worse or not help at all.

If you did try that, probably the most common reasons you end up with bad geometry are that you leave Create Caps on when using the Extrude tool (see screenshot) when you shouldn’t and that creates duplicated geometry or that you have used and then edited 3D models you’ve downloaded from other sources and they have been created badly in the first place.

create_caps