Expresso: ThinkingParticles and MoGraph Cloner


#1

Hi all,

I have a MoGraph Cloner setup set to Object mode, where a TP particle group is being used as the framework for cloning. The object being cloned is a simple mesh sphere, though the Cloner has MoGraph Multi-Shader applied to it so that the particles are 5 different colors.

After a couple test renders, I’m noticing that once I have cached my clones to disk using the MoGraph Cache tag, C4D only renders a fraction of the clones. Here’s a side-by-side-comparison: https://www.dropbox.com/s/k4xq8teg9bzfdms/cached_v_uncached.mp4?dl=0

Also, here’s my scene file: https://www.dropbox.com/s/4nhz9hnjn5if40o/VID1_Shot05_Disintegration_v13_mograph-cache-test_more2.c4d?dl=0

I did a test in AfterEffects to make sure things line up, and sure enough they do - the only problem is that the cached version is missing what looks to be about half of its clones. Is this normal behavior for the tag, or have I missed something in the setup?

Thanks ahead of time for any insights…

NpF


#2

Hi Pfistar,
to begin, it appears that there are a few “oddities” in your XPRESSO setup and it’s making it hard to troubleshoot.
If you have some time, can you start with the following, and then upload a new file if the problems persist:

  1. I can see from your XPRESSO setup that you are feeding the “NUCLEUS.T1” object into a Tag node, set to XPRESSO, and then that into an Object node, and then that into a Math:multiply. That seems to be an oversight from your part.
  2. On the same Node setup you have a PSetData node that doesn’t receive any particle input.
  3. You have your LOD set to “Low” in the Viewport menu “Options” -> “Level of Detail”. Set that to High
  4. Also please remove all Cells except one, to make things simpler.

If you look at the above, and still having problems, please repost a new scene and I’ll take a look later.


#3

And so it appears the only thing that made a difference is the LOD setting…