Emissive objects behind glass - not showing in emission AOV


Hi, I have a car model, in which the head and tail lights are placed behind the glass-like/ transparent case. The problem is that I’m not getting any of the emission information in the emission AOV, but rather in the “transmission indirect” AOV.

This makes sense as technically, I’m getting the data through the glass, hence the transmission contribution. However this is a problem during compositing when I need to add a glow only to the lights and not the other glass objects that also have “transmission indirect” contributions. Unfortunately I can’t use cryptomatte or matte passes as a workaround here as the objects/material ids would be covered by the matte assigned to the glass object/material in front of it.

Does anyone know how to approach this kind of issue? I’ll include screenshots to explain the problem visually.
PS: I’m using Arnold, Maya 2018



Vray has a setting for its shaders under Refraction that will pass all the aovs into the frame buffer - I would hope arnold would have a similar thing somewhere


Thanks for the reply. Yeah, I went through the documentation a bit more carefully and there does seem to be a checkbox to “transmit AOVs” through refractive materials. I’ll give that a go.