Displacements are all wiggly and artifacted. What's the deal?


#1

I’m using Redshift v2.6 in C4D v20

So here’s my displacement image mapped as a diffuse texture. It’s pretty dark clean I think. I believe it’s 8k for cleanest displacement.
CaptureB

However when I apply the image as a displacement, it looks like this:
captureA

It only seems to happen when I enable tessalation in the redshift tag. Once I turn that off it looks fine, but I need the tesselation to smooth out the edges of the model.

Any thoughts?


#2

Try turning off the automatic bump in the displacement settings of the RS Object tag. You might need a little more subdivision also.


#3

Turning off automatic bump makes it WAY worse.
CaptureC

I’ve got my subdivisions cranked to 16 in the redshift tag. Can’t get any higher than that.


#4

Are you using a 16-bit image? Also, what sort of lighting setup do you have?


#5

You could use a displacement map …

Emboss


#7

Wat?

That’s what I’m doing. That’s what this post is about.
Am I misunderstanding you?


#8

No, it’s not a 16 bit image. Will that make a big difference? There are only two colors in the displacement map. Black, and 50% gray.

I have an HDRI that I built that I’m using for the lighting.


#9

I only used a B/W image for my results … You could also add some texture with a bump map with .5 noise.

BTW, I’m using the standard c4d render … no 3rd party engine


#10

OK. I had you turn off the automatic bump because it is using normal mapping to replace some detail that you would get from true displacement. That allowed you to see what’s really going on. You should almost NEVER need to go to 16 subdivision levels in the RS tag. You either need to subdivide your original mesh, or put it in a subdivision generator (used to be called Hypernurbs I think)

Barring that, I would like to ask…do you really need displacement for this? or could you get away with normal mapping? (And I don’t mean the kind automatically created in the displacement settings, but rather building normal mapping using a normal map and the bump map node piped into RS material…overall…bump.

I personally find the displacement in C4D when using Redshift to be a bit wonky.

It is usually best to have some antialiasing in your maps, rather than straight from one color to the next, which can, and most likely will cause stair stepping.

I don’t believe your lighting has anything to do with this issue.

If you could post a small sample file, we could take a look and get a better idea what is going on.


#11

16-bit images are best for displacements otherwise you get really obvious aliasing and stair-stepping – even with blurred texture maps. I only asked about lighting because the shadows looked low-res; I don’t know if Redshift has a way of increasing shadow resolution.


#12

Redshift displacement is a bit tricky. Personally, like a lot of things in redshift, I dont love the workflow–its not really straightforward.

Heres a tip that doesnt answer your question but can be useful.

What I will do sometimes is load a wireframe shader node into the diffuse color port to help you better see the actual subdivision. Then you can start playing with the displacement settings and get more detail.


#13

That’s very affiriming Joel. I have always felt like displacement in Redshift, at least in C4D, is tricky and fussy compared to Standard or Physical. It’s one of the trade-offs I’ve had to live with to get that RS workflow and speed that I love though.

Seems to work better with procedural maps than it does with raster images.


#14

you shouldn’t need to crank your subdivisions that high.

Try turning down the minimum edge length in the RS object tag. I find the default setting of 4 is a too high for detailed displacements.


#15

Yes! This. I always forget that setting.