Cycles, Fur and Animation: Anyone got presets for flicker-free rendering?


#1

Hello;

since the recent changes in VRay force me to abandon that renderer, I got myself the Cycles demo version and play with the most important feature for me: Fur in animation.

Unfortunately, so far I got a strong flicker in the finished rendering (no motion blur), Of course fur is somewhat prone to create flicker due to the hairs creating a high-frequency light pattern. Ironing the details with the denoiser is not an option though. I have increased the samples already; so far with insufficient results. (I have to admit that the equivalent almost-no-flicker images in VRay animation take twice as long as my most recent Cycles experiments so there is still room to brute-force more.)

I know that fur in Cycles works well enough - Big Buck Bunny is using several furred characters. Looking into the sources for that movie in Blender itself could be a possible next step, but the demo only runs 30 days, and I am not sure how long digging into the Blender side would take*.

Does anybody have fitting settings at hand to create flicker free fur in Cycles animation? If possible, with explanation for the decisive switches? (Settings in C4D fur object, C4D fur material, Cycles material, Cycles renderer… all working together…)

The internet doesn’t give much info on so specific a topic so far. Thanks for looking.

(*) Oops. I remember that Big Buck Bunny has been out for a few years, that may not even have been rendered with Cycles at that time…


#2

Hi Cairyn.

I don’t know the answer to your question, but you can join their official Discord forum. Usually they (or someone) respond really fast.

Here is a invite…


#3

Thanks, I got an answer from the Discord and rendered a little. Here is a set of hints so we have the answer in the thread:

  • Under Render Settings for Cycles 4D, set the Seed in the Integrator area to 1.
    Apparently, with the default value 0, the sampling is randomized per frame. If you render a still image as a sequence, you will notice that there is noise in the fur (and probably elsewhere) although nothing in the image changes. The Seed value of 1 freezes that randomization, and the still sequence will result in pixel-identical images.

However, that is not sufficient to make an actual animation flicker-free, since the hairs still have high-frequency illumination. To dampen the noise, I set the samples to 50 and applied a denoiser with radius 3. This gave me the desired quality animation.

Note that I am not sure whether the two last steps are necessary in this form, and whether less samples would be sufficient, or whether the denoiser is needed at all. Most likely the hair structure and thickness will also play into the results. I didn’t have the time to go through many more iterations yet, but I will continue to experiment.